Error getting validation data (2)


#1

Dear team,
Just ran into an issue after you updated the FreeBSD dehydrated port some time ago.
Current version: dehydrated-0.6.1.7

Can you tell me if this is a server time out issue or is it caused by the recent update?
best regards, Jos

My domain is: cloudzeeland.nl
I ran this command: periodic weekly (FreeBSD)
My web server is (include version): apache24-2.4.33
The operating system my web server runs on is (include version): FreeBSD 10

It produced this output:


Checking Let’s Encrypt certificate status:

INFO: Using main config file /usr/local/etc/dehydrated/config

Processing cloudzeeland.nl with alternative names: www.cloudzeeland.nl

  • Checking domain name(s) of existing cert… unchanged.
  • Checking expire date of existing cert…
  • Valid till Apr 26 11:37:22 2018 GMT (Less than 30 days). Renewing!
  • Signing domains…
  • Generating private key…
  • Generating signing request…
  • Requesting authorization for cloudzeeland.nl…
  • Requesting authorization for www.cloudzeeland.nl…
  • 2 pending challenge(s)
  • Deploying challenge tokens…
  • Responding to challenge for cloudzeeland.nl authorization…
    ERROR: Challenge is invalid! (returned: invalid) (result: {
    “type”: “http-01”,
    “status”: “invalid”,
    “error”: {
    “type”: “urn:acme:error:connection”,
    “detail”: “Fetching https://www.cloudzeeland.nl.well-known/acme-challenge/_SfVw162d3Hadrqy0mH07klmeWON-GrM9uf7cdzpr0c: Error getting validation data”,
    “status”: 400


#2

The server is redirecting http://www.cloudzeeland.nl/abc to https://www.cloudzeeland.nlabc.

Check the Apache configuration for something like “Redirect / https://www.cloudzeeland.nl” and add a “/” to the end so it’s “Redirect / https://www.cloudzeeland.nl/”.


#3

Thanks, that worked! Much appreciated.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.