Error generating certbot certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
sudo certbot --nginx -d

It produced this output:

"Saving debug log to /var/log/letsencrypt/letsencrypt.log
Requesting a certificate for

Certbot failed to authenticate some domains (authenticator: nginx). The Certificate Authority reported these problems:
Type: connection
Detail: Fetching Timeout during connect (likely firewall problem)

Hint: The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx server and that it is accessible from the internet.

Some challenges have failed."

My web server is (include version): nginx/1.21.4

The operating system my web server runs on is (include version):
Ubuntu 22.04 64bit with CloudPanel

My hosting provider, if applicable, is: hostinger

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.21.0

Port 80 needs to be open for the --nginx plugin (which is using the http-01 challenge) to work. Currently, neither port 80, nor port 443 (which would be used for HTTPS) are open.


hey Osiris thanks for replying. I have been having this problem for days now of research. what commands do i run to open port 80

1 Like

I don't know, it could be the Ubuntu firewall (ufw), perhaps CloudPanel has some firewall options (isn't CloudPanel a control panel by the way?) or maybe even Hostinger has some firewall settings somewhere.

1 Like

i check the ufw status and its inactive but in the vps hpanel it does have a fire


and this one as well do you know how to create a firewall config?

I do not, maybe someone else might know. I don't have experience with Hostinger.

1 Like

ok thanks for replying

1 Like

can you tell me the command you ran to test if port 80 is open?

I used curl -LIv, but there are many other methods.


ok thanks for helping out. should i repost the topic for someone else to assist me? i still cant figure this out

Someone else might visit this thread the upcoming days. Or maybe not. Either way, it's up to you to also ask for help elsewhere.

I'm not sure where the firewall issue actually resides, so maybe a generic computer forum might be best?


I agree with @Osiris; I don't think there's really much else for people here to do. First get your website working and accessible to the public, and then if you're still having trouble getting a certificate we can try to help you understand why that part isn't working.


Ok i will work on that thanks.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.