Error DNS problem: NXDOMAIN looking up TXT - Plugin dns-ovh


#1

My domain is: dev.cristal-sons.be

I ran this command:

certbot certonly --dns-ovh --dns-ovh-credentials ovh.ini --dns-ovh-propagation-seconds 60 -d dev.cristal-sons.be

It produced this output:

Failed authorization procedure. dev.cristal-sons.be (dns-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.dev.cristal-sons.be

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: dev.cristal-sons.be
   Type:   None
   Detail: DNS problem: NXDOMAIN looking up TXT for
   _acme-challenge.dev.cristal-sons.be

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0-2.el7

Thx!


#2

Hi @venizia03

looks like your propagation is too short.

Your zone ( https://check-your-website.server-daten.de/?q=dev.cristal-sons.be )

Domain: dev.cristal-sons.be
Primary: dns109.ovh.net
Mail: tech.ovh.net
Serial: 2019031814
Refresh: 86400
Retry: 3600
Expire: 3600000
TTL: 300
num Entries: 2

has a TTL of 300 seconds.

Perhaps add the

--debug-challenges

parameter, then certbot waits with the next step. So you can recheck your domain and test, if the _acme-challenge - entry is visible.


#3

Does it find the file “ovh.ini”?
Are those credentials still valid?

Are you running certbot as root?


#4

Yes to all your questions :slight_smile: I even regenerated the API keys just to be sure.


#5

@JuergenAuer,

I used this command since a long time without issue. It started today. I will try your suggestions : adding a greater TTL in command and the debug challenges option.

Thx!


#6

Not sure what happened but after 2 other attempts, the command works. Maybe an issue with the OVH API?


#7

Yep, that’s always possible. Monday-morning - API :wink:


closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.