Error creating new order :: too many failed authorizations recently

Hello. I always use traefik to obtain certificates and usually it works fine. This time with this specific domain it produces an error.

I started to get certificate through sslforfree.com but didn’t finish proccess because we decided to set up VPS with docker and traefik as usual we do. Maybe it has something to do with this error. Traefik works with other domains, so it has to be something wrong with this one. Can someone help me?

My domain is: yakovlev.studio

I ran this command: I use traefik docker image and acme-challenge

It produced this output: traefik | time=“2020-03-18T09:43:55Z” level=error msg="Unable to obtain ACME certificate for domains “yakovlev.studio,www.yakovlev.studio” detected thanks to rule “Host:yakovlev.studio, www.yakovlev.studio” : unable to generate a certificate for the domains [yakovlev.studio www.yakovlev.studio]: acme: error: 429 :: POST :: https://acme-v02.api.letsencrypt.org/acme/new-order :: urn:ietf:params:acme:error:rateLimited :: Error creating new order :: too many failed authorizations recently: see https://letsencrypt.org/docs/rate-limits/, url: "

My web server is (include version): docker image nginx:latest. traefik:v1.7

Hi @denko

your setup doesn’t work, so you have failed orders.

That’s not a problem of your previous sslforfree - usage.

Wait, then try it again. Then check the real error why the validation fails.

there is no dns record for this domain. this is the reason your authorizations failed. (or one of the reasons)

this points to 176.31.214.54: is it correct?

but good news: this ratelimit resets in one hour.

IP for yakovlev.studio is correct. www.yakovlev.studio I just added DNS.

Yeah, that was the first mistake.

Second one I didn’t do traefik.enable=false for the traefik container. So it tried to obtain certificate for that container as well.

Ok. I’ll wait then…

It works now. Thank you for replies.