Error creating new order - certbot sees incorrect domain?

My domain is:

I ran this command: sudo certbot --apache

It produced this output:

Which names would you like to activate HTTPS for?
We recommend selecting either all domains, or all domains in a VirtualHost/server block.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 1
Requesting a certificate for
An unexpected error occurred:
Error creating new order :: Cannot issue for "": The ACME server refuses to issue a certificate for this domain name, because it is forbidden by policy
Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): (I'm not sure what to put here, sorry. I'm trying to run a phpbb forum on a local machine)

The operating system my web server runs on is (include version): Ubuntu 22.04.2 LTS x86_64

My hosting provider, if applicable, is: (N/A, locally hosted)

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 2.6.0

Sorry if I answered anything incorrectly above, I'll try to elaborate as best I can - this is only my second time ever touching domain names and the first time I've done anything with SLL certs. Basically, I have a local box that I've installed a phpbb forum onto. The forum seems to be working fine, and I've attached my domain to it successfully, so I went to let's encrypt to get a SSL cert set up.

Everything works fine until I run the command to actually create a cert - the only visible choice is "", which is definitely not my domain. Running "apachectl -S" returns these results:

VirtualHost configuration:
*:80                   is a NameVirtualHost
         default server (/etc/apache2/sites-enabled/000-default.conf:1)
         port 80 namevhost (/etc/apache2/sites-enabled/000-default.conf:1)
         port 80 namevhost (/etc/apache2/sites-enabled/phpbb.conf:1)

I'm stumped on what to do from here, and I'm genuinely unsure where to start troubleshooting - has anyone seen a similar issue to this? Apologies if this question isn't appropriate for the forums here

all links in your website are reletive links, so I think you were just getting this because as default virtualhost (ip virtualhost skips even if it has default tag on it)
I think you should look at phpbb.conf (likely top of it)


Hi @PlainJane, and welcome to the LE community forum :slight_smile:

Are you on the right system?
Please show whichever of these can produce an IPv4 address:
curl -4
curl -4


If is literally in that configuration file and is not your domain name (which is obviously isn't), you probably want to reconfigure phpbb.conf so its ServerName directive is correct.


oh my god, i somehow didn't see the file tree in the output there (in my defense, it was a long day)

I navigated to the phpbb.conf in there, replaced the domain with mine, and it worked fine first try - thank you for the help!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.