Error creating a certificate with hostname Duck DNS


I have tried a few times to create a certificate using the standard acme procedure with a Duck DNS hostname: --issue --dns dns_duckdns -d -d *

but I always get the error:

Error, can not get domain token "type":"dns-01","url":"","status":"invalid","error":

The same procedure with a different service has worked smoothly.

Can you please help? Where am I wrong?


1 Like

The default Certificate Authority (CA) for is ZeroSSL which is what you tried.

Use the --server option to set Let's Encrypt. You can even change the default CA


Thanks! It has worked.

But I am wondering, why the command:

./ --issue --dns dns_dynu -d -d *

has perfectly worded with and with Duck DNS it is necessary to use the --server option to set Let's Encrypt?

Thansk for helping, daniele

1 Like

I don't know. Was this a new setup with

Maybe your dynu certs were issued by ZeroSSL? Is that possible?

When you hide your domain names it is not possible to give specific advice


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.