Error al intentar renovar mis certificados

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://webmail.poderjudicialchiapas.gob.mx/?_task=logout

I ran this command:

sudo /usr/local/bin/certbot-auto --apache --no-bootstrap

It produced this output:

Creating virtual environment…
Installing Python packages…
Had a problem while installing Python packages.

pip prints the following errors:

Collecting ConfigArgParse==1.0 (from -r /tmp/tmp.eEHw7wWN2D/letsencrypt-auto-requirements.txt (line 12))
Downloading https://files.pythonhosted.org/packages/66/37/dd9fcb3b19c1dceea450ee994952e311a96dd827bb09ee19169c3427e0d3/ConfigArgParse-1.0.tar.gz (40kB)
ConfigArgParse requires Python ‘>=2.7, !=3.0., !=3.1., !=3.2., !=3.3., !=3.4.*’ but the running Python is 3.4.10

Certbot has problem setting up the virtual environment.

We were not be able to guess the right solution from your pip
output.

Consult https://certbot.eff.org/docs/install.html#problems-with-python-virtual-environment
for possible solutions.
You may also find some support resources at https://certbot.eff.org/support/ .

My web server is (include version):
SERVIDOR APACHE

The operating system my web server runs on is (include version):
CENTOS 6.10 FINAL

My hosting provider, if applicable, is:
TELMEX
I can login to a root shell on my machine (yes or no, or I don’t know):
SI

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): NO

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): desconozco

Server version: Apache/2.2.15

Hola @AlexisGarcia,

Pasé su pregunta a un colega del equipo Certbot y él me respondió (mi traduccion)

está ejecutando con --no-bootstrap, que dice a certbot-auto que el usuário se encargará de la instalación de las dependencias SO, pero la versión actual de Python que tiene en su sistema está Python 3.4, que ya no apoyamos. Básicamente diría una versión de lo que dice en
Certificate verify failed: unable to get local issuer certificate (_ssl.c:1108).

¿Puede entender el contenido del otro mensaje de mi colega en Inglés?

que pena yo esperaba poder actualizar todos mis certificados ya que no solo ese es el que necesito actualizar si no tengo otros sitios que tambien estan por caducar que me recomienda ay forma de actualizarlos de otra forma por favor ayudeme me siento muy preocupado por favor ing…

Lo que puede hacer es bajar una versión antigua de certbot-auto y usarla con --no-self-upgrade. Una versión que se puede usar en su sistema está disponsible en https://raw.githubusercontent.com/certbot/certbot/v1.0.0/certbot-auto.

@bmw dijó

CentOS 6 reaches its end of life in November meaning that all of the packages on your system will no longer receive security updates. If updating your OS isn’t feasible right now, your most reliable option is to use an old version of certbot-auto and include --no-self-upgrade on the command line. The last working version of certbot-auto on i686 CentOS 6 can be found at https://raw.githubusercontent.com/certbot/certbot/v1.0.0/certbot-auto . Including this flag means that you will not get any updates fixing bugs including security problems or compatibility issues with Let’s Encrypt’s servers.

en Español:

CentOS 6 llega a su fin de vida en noviembre, lo que significa que todos los paquetes en su sistema ya no recibirán actualizaciones de seguridad. Si la actualización de su sistema operativo no es factible en este momento, su opción más confiable es usar una versión anterior de certbot-auto e incluir --no-self-upgrade en la línea de comandos. La última versión de certbot-auto que funciona en i686 CentOS 6 se puede encontrar en https://raw.githubusercontent.com/certbot/certbot/v1.0.0/certbot-auto. La inclusión de este opción [--no-self-upgrade] significa que no recibirá actualizaciones que corrijan errores, incluidos problemas de seguridad o problemas de compatibilidad con los servidores de Let’s Encrypt.

(traducción automática, con algunas correcciones)

1 Like