Error activating SSL in my VPS Plan

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot --apache -d -d (there were other commands which i can before this so if i share in sequence then they are --


It produced this output: Gave an error

My web server is (include version): i dont know

The operating system my web server runs on is (include version): bought vps plan and have installed " Ubuntu 22.04 64bit"

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):no, not using control panel.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):i dont know

The error message means exactly what it says--while you have DNS records for, you don't for Either create the latter, or remove that hostname from your request.


Hi @op12, and welcome to the LE community forum :slight_smile:

I see the DNS error:
And I also you that your authoritative DNS servers are:    nameserver =    nameserver =

Aren't those from GoDaddy?
I only ask because you mentioned:
You mention:

Does the DNS problem persist?
Have you tried testing against the staging environment?
sudo certbot --apache --dry-run


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.