Error 502 after ssl renewal

My domain is: tech4greece.gr

I ran this command: ee site update tech4greece.gr --letsencrypt

It produced this output: Renewing certificate for domain tech4greece.gr.
Certificate received
Certificate stored
Certificate renewed successfully!
Success: SSL verification completed.
Starting site’s services.
Success: SSL renewal completed.

My web server is (include version): lemp nginx with easyengine v4

The operating system my web server runs on is (include version): ubuntu 18.04

My hosting provider, if applicable, is: digitaloean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): wordpress

After the successful renewal I get error 502 when I try to load my website. I am using cloudflare if that maters.

You have a very… “custom” config:

  • EasyEngine v4
  • WordPress
  • CloudFlare
  • Ubuntu 18.04
  • NGINX

I don’t think you will find much knowledgeable help on EE on this forum.
But perhaps we can still resolve your issues in some other way…

Let’s start with the simplest: NGINX.
Let’s see which (server/domain) names are covered by it:
Try:
nginx -T | grep server_name

Command ‘nginx’ not found, but can be installed with:

Tell me the output of docker ps

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
a93c286c22b7 easyengine/nginx:v4.1.0 “/usr/bin/openresty …” 4 days ago Restarting (1) 23 seconds ago tech4greecegr_nginx_1
42065aa277f1 easyengine/cron:v4.0.0 “/usr/bin/ofelia dae…” 3 months ago Up 22 hours ee-cron-scheduler
6d6c2842039f easyengine/postfix:v4.0.0 “postfix start-fg” 3 months ago Up 22 hours 25/tcp tech4greecegr_postfix_1
4e85f8c913d2 easyengine/php:v4.1.2 “docker-entrypoint.s…” 3 months ago Restarting (78) 14 seconds ago tech4greecegr_php_1
509e735db8d6 easyengine/mariadb:v4.0.0 “docker-entrypoint.s…” 3 months ago Up 22 hours 3306/tcp services_global-db_1
fd5f3fb1e90d easyengine/redis:v4.0.0 “docker-entrypoint.s…” 3 months ago Up 22 hours 6379/tcp services_global-redis_1
30b6e2af4fc1 easyengine/nginx-proxy:v4.0.3 “/app/docker-entrypo…” 3 months ago Up 22 hours 0.0.0.0:80->80/tcp, 0.0.0.0:443->443/tcp services_global-nginx-proxy_1

find a directory with a docker-compose.yml file, and run docker-compose logs

I located one but when I try to cd I get that response -bash: cd: /root/opt/easyengine/services/docker-compose.yml: No such file or directory

cd /root/opt/easyengine/services/ ; docker-compose logs

ERROR:
Can’t find a suitable configuration file in this directory or any
parent. Are you in the right directory?

    Supported filenames: docker-compose.yml, docker-compose.yaml

I don’t get it. Is the file there or not?

root@tech4greece-wp:~# locate docker-compose.yml
/opt/easyengine/services/docker-compose.yml
/opt/easyengine/sites/tech4greece.gr/docker-compose.yml
/var/lib/docker/overlay2/dd1d2b0af16197b8b2e77b98d88c3878418d5ced34d14d36fc6b2c52fdd9e8dc/diff/app/docker-compose.yml
/var/lib/docker/overlay2/e9cb03be26ae926dd226c2b62173c8328fda3875c26a4bb447dac20e09d150ac/merged/app/docker-compose.yml

this should be the right one.

I tried that cd /opt/easyengine/sites/tech4greece.gr/ ; docker-compose logs
and I got something like this but a ton more
php_1 | [05-May-2020 09:54:20] ERROR: failed to post process the configuration
php_1 | [05-May-2020 09:54:20] ERROR: FPM initialization failed
php_1 | [05-May-2020 09:55:21] ERROR: failed to open error_log (/var/log/php/error.log): Permission denied (13)
php_1 | [05-May-2020 09:55:21] ERROR: failed to post process the configuration
php_1 | [05-May-2020 09:55:21] ERROR: FPM initialization failed

This is pretty strange, you should check if easyengine has a community to search.

2 Likes

I tried but no one answered. Is there anything else to do or should I backup my data and re install everything?

You should try upgrading before.

Then you can try to fix the appropriate permissions.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.