ERR_SSL_PROTOCOL_ERROR when trying to access

Hey,

when i try to access my Domain im recieving an Error: ERR_SSL_PROTOCOL_ERROR

But when i go for sudo ./certbot-auto renew it tells me :Cert not yet due for renewal

My Domain is: git.taut-fl.de

Whats the problem here?

Thank you guys!

$ printf "GET /\r\n" | nc git.taut-fl.de 443 | head -c 20
<html><head><meta ht
$ _

You serve plain HTTP on port 443.

I have a reverse proxy behind this domain which redirects to my gogs git service… i can access my gogs service from intern.

Must be a problem with the cert.

I received a mail that my cert expires at 19th July. But no renew is available as i said in my first post.

Can I check the status of my domains cert anywhere?

No, it really isn't. Your server is providing HTTP responses to requests made to the HTTPS port. It's a server misconfiguration.

It already worked for me.

I send all requests to https with override and then reverse proxy them to my internal ip via http…

Didn’t change anything that’s why I don’t know what is going on.

It just stopped working. :joy:

./certbot-auto certificates to check locally,

https://crt.sh/?Identity=%&iCAID=16418

to check the public database.

However, I agree with @mpalmer that this problem is unlikely to be related to certificate expiry and is likely to be related to web server configuration. (It's possible that these two things are combined because maybe you ran a Certbot renewal command that changed your configuration—though most forms of renewal with Certbot don't try to do that!—and resulted in an invalid configuration serving HTTP on port 443.)

I fixed it. Really crazy…

I deleted the HTTPS part from the apache configfile and then tried to access my system via http. That worked. Then put back in the https stuff, reload and it worked.

Really weird.

Thank you guys!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.