Err_cert_authority_invalid

Hello!
It was still OK until this morning, I got error ERR_CERT_AUTHORITY_INVALID with my web
My domain is: https://mij.vn, every sub-domain is redirect to https://mij.vn

I try to renew certificate but nothing change. When I check with

echo | openssl s_client -connect mij.vn:443 -servername mij.vn 2>/dev/null | awk ‘/Certificate chain/,/—/’

It produced this output:

Certificate chain
0 s:/C=US/O=Unspecified/CN=mij/emailAddress=root@mij
i:/C=US/O=Unspecified/OU=ca-1819607018640839785/CN=mij/emailAddress=root@mij
1 s:/C=US/O=Unspecified/OU=ca-1819607018640839785/CN=mij/emailAddress=root@mij
i:/C=US/O=Unspecified/OU=ca-1819607018640839785/CN=mij/emailAddress=root@mij

And apache ssl_error_log showed

mij.vn:443:0 server certificate does NOT include an ID which matches the server name

My web server is (include version): apache 2.4

The operating system my web server runs on is (include version): amazon linux 2

I can login to a root shell on my machine.
Please help me! Thank you so much

1 Like

What command did you run?

The cert you showed seems to be self-signed.

1 Like

Yep, I run

sudo certbot --force-renew

It was OK and I got the new one
apache look like OK be cause I can test access with OK status

1 Like

Please show out of:
certbot certificates
and also
apachectl -S

1 Like

certbot certificates is

Renewal configuration file /etc/letsencrypt/renewal/mij.vn-0001.conf produced an unexpected error: expected /etc/letsencrypt/live/mij.vn-0001/cert.pem to be a symlink. Skipping.
Renewal configuration file /etc/letsencrypt/renewal/mij.vn-0002.conf produced an unexpected error: expected /etc/letsencrypt/live/mij.vn-0002/cert.pem to be a symlink. Skipping.


Found the following certs:
Certificate Name: mij.vn
Domains: mij.vn www.mij.vn
Expiry Date: 2020-02-28 23:38:27+00:00 (VALID: 89 days)
Certificate Path: /etc/letsencrypt/live/mij.vn/fullchain.pem
Private Key Path: /etc/letsencrypt/live/mij.vn/privkey.pem

The following renewal configurations were invalid:
/etc/letsencrypt/renewal/mij.vn-0001.conf
/etc/letsencrypt/renewal/mij.vn-0002.conf

and apachectl -S

VirtualHost configuration:
18.139.18.255:8080 ossec.mij.vn (/etc/httpd/conf.d/ossec-wui.conf:2)
*:443 is a NameVirtualHost
default server mij.vn (/etc/httpd/conf.d/ssl.conf:56)
port 443 namevhost mij.vn (/etc/httpd/conf.d/ssl.conf:56)
port 443 namevhost mij.vn (/etc/httpd/conf.d/vhost-le-ssl.conf:2)
port 443 namevhost www.mij.vn (/etc/httpd/conf.d/vhost-le-ssl.conf:28)
*:80 mij.vn (/etc/httpd/conf.d/vhost.conf:1)
ServerRoot: “/etc/httpd”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/etc/httpd/logs/error_log”
Mutex authn-socache: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/run/httpd/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex cache-socache: using_defaults
Mutex authdigest-opaque: using_defaults
Mutex watchdog-callback: using_defaults
Mutex proxy-balancer-shm: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex authdigest-client: using_defaults
Mutex lua-ivm-shm: using_defaults
Mutex ssl-stapling: using_defaults
Mutex proxy: using_defaults
PidFile: “/run/httpd/httpd.pid”
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name=“apache” id=48
Group: name=“apache” id=48

1 Like

You have the same domain name covered by two different configs.

1 Like

And there is a problem in your renewal folder.
Please show:
ls -l /etc/letsencrypt/renewal/

1 Like

I don’t kwon how it showed that, because my ssl.conf is default, I did not change anything on ssl.conf

Here is mine

-rw-r–r-- 1 root root 514 10月 22 13:35 mij.vn-0001.conf
-rw-r–r-- 1 root root 514 10月 22 14:16 mij.vn-0002.conf
-rw-r–r-- 1 root root 489 12月 1 07:38 mij.vn.conf

1 Like

You didn’t have to (change it there).
It can happen, even when you change the default server name anywhere else.
If you want to “see” the conflict, please show line 56 of ssl.conf.

I would delete the 0001 and the 0002 conf files.

1 Like

56 line is
56 <VirtualHost\ _default_:443>

I would delete the 0001 and the 0002 conf files.

I had deleted but nothing change

So “default” matches the name given elsewhere (like in: /etc/apache2/apache2.conf)

Please show file:
/etc/httpd/conf.d/vhost-le-ssl.conf

Here is it

 <IfModule mod_ssl.c>
<VirtualHost *:443>
  ServerAdmin admin@localhost
  ServerName mij.vn 
  DocumentRoot /var/www/mij/public
  <Directory /var/www/mij/public/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    Allow from all
    Require all granted
  </Directory>
  SetEnvIf Remote_Addr "127\.0\.0\.1" ignore_log
  SetEnvIf Request_URI "\.gif$|\.jpg$|\.png$|\.svg$|\.jpeg$|\.css$|\.js$|\.ico$" ignore_log
  CustomLog "logs/ssl_access_log" combined env=!ignore_log
  CustomLog "logs/ignore_log" combined env=ignore_log
RewriteEngine on
# Some rewrite rules in this file were disabled on your HTTPS site,
# because they have the potential to create redirection loops.

# RewriteCond %{SERVER_NAME} =mij.vn
# RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateFile /etc/letsencrypt/live/mij.vn/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/mij.vn/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/mij.vn/chain.pem
</VirtualHost>
<VirtualHost *:443>
  ServerAdmin admin@localhost
  ServerName www.mij.vn
  Redirect permanent / https://mij.vn/ 
SSLCertificateFile /etc/letsencrypt/live/mij.vn/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/mij.vn/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
</VirtualHost>
</IfModule>

there are two openings for virtual host and no closings…

please edit that post and add three backticks at the top on a line by themselves:
Like these (you can copy paste them):
```

OK the two names (mij.vn and www.mij.vn) use the same cert.
So, you will need to ensure the cert has both names on it.
That said, I don’t see anything wrong.
You simply need to find the conflicting servername directive in the apache2.conf file and change it to anything else (like: servername not.used;)
See output of:
grep -Eri 'servername|serveralias' /etc/apache2/

Here is it

/etc/httpd/conf.d/ssl.conf:#ServerName www.example.com:443
/etc/httpd/conf.d/ossec-wui.conf:     ServerName ossec.mij.vn
/etc/httpd/conf.d/ossec-wui.conf:     ServerAlias www.ossec.mij.vn
/etc/httpd/conf.d/vhost.conf:  ServerName mij.vn 
/etc/httpd/conf.d/vhost.conf:#  ServerName dev.mij.vn
/etc/httpd/conf.d/vhost-le-ssl.conf:  ServerName mij.vn 
/etc/httpd/conf.d/vhost-le-ssl.conf:  ServerName www.mij.vn
/etc/httpd/conf/httpd.conf:# ServerName gives the name and port that the server uses to identify itself.
/etc/httpd/conf/httpd.conf:#ServerName www.example.com:80

hmm… Maybe your apache is older than I thought.
I wonder, do you even need the ssl.conf file?
Please show it.

Here is my ssl.conf, It’s default

#
# When we also provide SSL we have to listen to the 
# the HTTPS port in addition.
#
Listen 443 https

##
##  SSL Global Context
##
##  All SSL configuration in this context applies both to
##  the main server and all SSL-enabled virtual hosts.
##

#   Pass Phrase Dialog:
#   Configure the pass phrase gathering process.
#   The filtering dialog program (`builtin' is a internal
#   terminal dialog) has to provide the pass phrase on stdout.
SSLPassPhraseDialog exec:/usr/libexec/httpd-ssl-pass-dialog

#   Inter-Process Session Cache:
#   Configure the SSL Session Cache: First the mechanism 
#   to use and second the expiring timeout (in seconds).
SSLSessionCache         shmcb:/run/httpd/sslcache(512000)
SSLSessionCacheTimeout  300

#   Pseudo Random Number Generator (PRNG):
#   Configure one or more sources to seed the PRNG of the 
#   SSL library. The seed data should be of good random quality.
#   WARNING! On some platforms /dev/random blocks if not enough entropy
#   is available. This means you then cannot use the /dev/random device
#   because it would lead to very long connection times (as long as
#   it requires to make more entropy available). But usually those
#   platforms additionally provide a /dev/urandom device which doesn't
#   block. So, if available, use this one instead. Read the mod_ssl User
#   Manual for more details.
SSLRandomSeed startup file:/dev/urandom  256
SSLRandomSeed connect builtin
#SSLRandomSeed startup file:/dev/random  512
#SSLRandomSeed connect file:/dev/random  512
#SSLRandomSeed connect file:/dev/urandom 512

#
# Use "SSLCryptoDevice" to enable any supported hardware
# accelerators. Use "openssl engine -v" to list supported
# engine names.  NOTE: If you enable an accelerator and the
# server does not start, consult the error logs and ensure
# your accelerator is functioning properly. 
#
SSLCryptoDevice builtin
#SSLCryptoDevice ubsec

##
## SSL Virtual Host Context
##

<VirtualHost _default_:443>

# General setup for the virtual host, inherited from global configuration
#DocumentRoot "/var/www/html"
#ServerName www.example.com:443

# Use separate log files for the SSL virtual host; note that LogLevel
# is not inherited from httpd.conf.
ErrorLog logs/ssl_error_log
TransferLog logs/ssl_access_log
LogLevel warn

#   SSL Engine Switch:
#   Enable/Disable SSL for this virtual host.
SSLEngine on

#   SSL Protocol support:
# List the enable protocol levels with which clients will be able to
# connect.  Disable SSLv2 access by default:
SSLProtocol all -SSLv3

#   SSL Cipher Suite:
#   List the ciphers that the client is permitted to negotiate.
#   See the mod_ssl documentation for a complete list.
SSLCipherSuite HIGH:MEDIUM:!aNULL:!MD5:!SEED:!IDEA

#   Speed-optimized SSL Cipher configuration:
#   If speed is your main concern (on busy HTTPS servers e.g.),
#   you might want to force clients to specific, performance
#   optimized ciphers. In this case, prepend those ciphers
#   to the SSLCipherSuite list, and enable SSLHonorCipherOrder.
#   Caveat: by giving precedence to RC4-SHA and AES128-SHA
#   (as in the example below), most connections will no longer
#   have perfect forward secrecy - if the server's key is
#   compromised, captures of past or future traffic must be
#   considered compromised, too.
#SSLCipherSuite RC4-SHA:AES128-SHA:HIGH:MEDIUM:!aNULL:!MD5
#SSLHonorCipherOrder on 

#   Server Certificate:
# Point SSLCertificateFile at a PEM encoded certificate.  If
# the certificate is encrypted, then you will be prompted for a
# pass phrase.  Note that a kill -HUP will prompt again.  A new
# certificate can be generated using the genkey(1) command.
SSLCertificateFile /etc/pki/tls/certs/localhost.crt

#   Server Private Key:
#   If the key is not combined with the certificate, use this
#   directive to point at the key file.  Keep in mind that if
#   you've both a RSA and a DSA private key you can configure
#   both in parallel (to also allow the use of DSA ciphers, etc.)
SSLCertificateKeyFile /etc/pki/tls/private/localhost.key

#   Server Certificate Chain:
#   Point SSLCertificateChainFile at a file containing the
#   concatenation of PEM encoded CA certificates which form the
#   certificate chain for the server certificate. Alternatively
#   the referenced file can be the same as SSLCertificateFile
#   when the CA certificates are directly appended to the server
#   certificate for convinience.
#SSLCertificateChainFile /etc/pki/tls/certs/server-chain.crt

#   Certificate Authority (CA):
#   Set the CA certificate verification path where to find CA
#   certificates for client authentication or alternatively one
#   huge file containing all of them (file must be PEM encoded)
#SSLCACertificateFile /etc/pki/tls/certs/ca-bundle.crt

#   Client Authentication (Type):
#   Client certificate verification type and depth.  Types are
#   none, optional, require and optional_no_ca.  Depth is a
#   number which specifies how deeply to verify the certificate
#   issuer chain before deciding the certificate is not valid.
#SSLVerifyClient require
#SSLVerifyDepth  10

#   Access Control:
#   With SSLRequire you can do per-directory access control based
#   on arbitrary complex boolean expressions containing server
#   variable checks and other lookup directives.  The syntax is a
#   mixture between C and Perl.  See the mod_ssl documentation
#   for more details.
#<Location />
#SSLRequire (    %{SSL_CIPHER} !~ m/^(EXP|NULL)/ \
#            and %{SSL_CLIENT_S_DN_O} eq "Snake Oil, Ltd." \
#            and %{SSL_CLIENT_S_DN_OU} in {"Staff", "CA", "Dev"} \
#            and %{TIME_WDAY} >= 1 and %{TIME_WDAY} <= 5 \
#            and %{TIME_HOUR} >= 8 and %{TIME_HOUR} <= 20       ) \
#           or %{REMOTE_ADDR} =~ m/^192\.76\.162\.[0-9]+$/
#</Location>

#   SSL Engine Options:
#   Set various options for the SSL engine.
#   o FakeBasicAuth:
#     Translate the client X.509 into a Basic Authorisation.  This means that
#     the standard Auth/DBMAuth methods can be used for access control.  The
#     user name is the `one line' version of the client's X.509 certificate.
#     Note that no password is obtained from the user. Every entry in the user
#     file needs this password: `xxj31ZMTZzkVA'.
#   o ExportCertData:
#     This exports two additional environment variables: SSL_CLIENT_CERT and
#     SSL_SERVER_CERT. These contain the PEM-encoded certificates of the
#     server (always existing) and the client (only existing when client
#     authentication is used). This can be used to import the certificates
#     into CGI scripts.
#   o StdEnvVars:
#     This exports the standard SSL/TLS related `SSL_*' environment variables.
#     Per default this exportation is switched off for performance reasons,
#     because the extraction step is an expensive operation and is usually
#     useless for serving static content. So one usually enables the
#     exportation for CGI and SSI requests only.
#   o StrictRequire:
#     This denies access when "SSLRequireSSL" or "SSLRequire" applied even
#     under a "Satisfy any" situation, i.e. when it applies access is denied
#     and no other module can change it.
#   o OptRenegotiate:
#     This enables optimized SSL connection renegotiation handling when SSL
#     directives are used in per-directory context. 
#SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
<Files ~ "\.(cgi|shtml|phtml|php3?)$">
    SSLOptions +StdEnvVars
</Files>
<Directory "/var/www/cgi-bin">
    SSLOptions +StdEnvVars
</Directory>

#   SSL Protocol Adjustments:
#   The safe and default but still SSL/TLS standard compliant shutdown
#   approach is that mod_ssl sends the close notify alert but doesn't wait for
#   the close notify alert from client. When you need a different shutdown
#   approach you can use one of the following variables:
#   o ssl-unclean-shutdown:
#     This forces an unclean shutdown when the connection is closed, i.e. no
#     SSL close notify alert is send or allowed to received.  This violates
#     the SSL/TLS standard but is needed for some brain-dead browsers. Use
#     this when you receive I/O errors because of the standard approach where
#     mod_ssl sends the close notify alert.
#   o ssl-accurate-shutdown:
#     This forces an accurate shutdown when the connection is closed, i.e. a
#     SSL close notify alert is send and mod_ssl waits for the close notify
#     alert of the client. This is 100% SSL/TLS standard compliant, but in
#     practice often causes hanging connections with brain-dead browsers. Use
#     this only for browsers where you know that their SSL implementation
#     works correctly. 
#   Notice: Most problems of broken clients are also related to the HTTP
#   keep-alive facility, so you usually additionally want to disable
#   keep-alive for those clients, too. Use variable "nokeepalive" for this.
#   Similarly, one has to force some clients to use HTTP/1.0 to workaround
#   their broken HTTP/1.1 implementation. Use variables "downgrade-1.0" and
#   "force-response-1.0" for this.
BrowserMatch "MSIE [2-5]" \
         nokeepalive ssl-unclean-shutdown \
         downgrade-1.0 force-response-1.0

#   Per-Server Logging:
#   The home of a custom SSL log file. Use this when you want a
#   compact non-error SSL logfile on a virtual host basis.
CustomLog logs/ssl_request_log \
          "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

</VirtualHost> 

That looks pretty harmless.
Ok, your choice:

  • delete the ssl.conf file
  • keep the ssl.conf file and “reorder” the file load order
    [when apache encounters multiple matches it takes the first match]

I tried to change ssl.conf to ssl.conf.sample and got ERR_CONNECTION_REFUSED