Empty files fullchain.pem

i accidentally catenated wrong fie to fullchain.pem

How can i restore this file or download it i need for my combine.pem file

Ref: Expired certificate

  • List item


Can you try to reissue the certificate?

Tried to renew after i renew to and tells me ‘certificate not due for renewal’

It’s cert.pem plus chain.pem. Be careful that you don’t change the underlying symlinks in /etc/letsencrypt/live, or Certbot will get confused about the renewal status of your certificate.

1 Like

so i cat both files
cat cert.pem chain.pem > combined.pem

now when i start webserver i get error

root@vorman:/etc/letsencrypt/live/vorman.mooo.com# /etc/init.d/lighttpd start
[…] Starting lighttpd (via systemctl): lighttpd.serviceJob for lighttpd.service failed because the control process exited with error code.
See “systemctl status lighttpd.service” and “journalctl -xe” for details.

4.0K drwxr-xr-x 2 root root 4.0K Mar 3 18:49 .
4.0K drwx------ 3 root root 4.0K Sep 26 2018 …
0 lrwxrwxrwx 1 root root 39 Mar 3 18:36 cert.pem -> …/…/archive/vorman.mooo.com/cert7.pem
0 lrwxrwxrwx 1 root root 40 Mar 3 18:36 chain.pem -> …/…/archive/vorman.mooo.com/chain7.pem
4.0K -rw-r–r-- 1 root root 3.5K Mar 3 19:26 combined.pem
8.0K -rw-r–r-- 1 root root 5.2K Mar 1 2019 combined.pem.bk
0 lrwxrwxrwx 1 root root 44 Mar 3 18:36 fullchain.pem -> …/…/archive/vorman.mooo.com/fullchain7.pem
0 lrwxrwxrwx 1 root root 42 Mar 3 18:36 privkey.pem -> …/…/archive/vorman.mooo.com/privkey7.pem

i think i fucked this file

root@vorman:/etc/letsencrypt/live/vorman.mooo.com# cat /etc/letsencrypt/archive/vorman.mooo.com/fullchain7.pem

Try copying combined.pem into fullchain7.pem.

If that doesn’t work, check the more detailed error logs that are suggested by the output from lighttpd start.


found previous response from you

combined is

privkey.pem and fullchain.pem .

now it worked


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.