Dry run is success but fails on actual run

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: seguimosaprendiendo.educacion.rionegro.gov.ar

I ran this command:

This command works:
sudo certbot certonly --dry-run --webroot -w /path/to/webroot -d
seguimosaprendiendo.educacion.rionegro.gov.ar -m myworkmail

This one doesn’t:
sudo certbot certonly --webroot -w /path/to/webroot -d
seguimosaprendiendo.educacion.rionegro.gov.ar -m myworkmail

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for seguimosaprendiendo.educacion.rionegro.gov.ar
Using the webroot path webroot for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. seguimosaprendiendo.educacion.rionegro.gov.ar (h ttp-01): urn:ietf:params:acme:error:connection :: The server could not connect t o the client to verify the domain :: Fetching http://seguimosaprendiendo.educaci on.rionegro.gov.ar/.well-known/acme-challenge/zfVkcZgZ3-iah7NT0Mb7gERA3QBuuNW5SY peaZXQD7k: Timeout during connect (likely firewall problem)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: seguimosaprendiendo.educacion.rionegro.gov.ar
    Type: connection
    Detail: Fetching
    http://seguimosaprendiendo.educacion.rionegro.gov.ar/.well-known/acme-challen ge/zfVkcZgZ3-iah7NT0Mb7gERA3QBuuNW5SYpeaZXQD7k:
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): Apache 2.4.29

The operating system my web server runs on is (include version): ubuntu 18.04

My hosting provider, if applicable, is: Huawei cloud

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

If I put a file in the acme-challenge folder, i can see it, website works, but can’t get the Cert.
My vm is behind a load balancer in the huawei cloud. and the instance is part of an autoscalable group.

Is your firewall blocking IP addresses?

They all respond the same?

No, firewall is not blocking ip’s

Currently there is only one instance up, there is not enough load to get more than one currently.

Are you sure? I can’t connect to your website. (and neither can letsdebug)

1 Like

Port 80 should be doing a 403 redirect to https, I’l switch around apache configs and try again

port 80 does nothing at all from my ip. I doubt I even get to apache.

you mean 301

Yeah, sorry for the delay, I managed to fix it, thanks to you pointer on the port 80.
The instance was behind a load balancer, and wasn’t properly set the backend for port 80, but yes in the 443. With that solved, everything worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.