DNS problem: SERVFAIL looking up A for sub.domain.tld


#1

Hello,
I’ve read many threads about this issue but it seems that there is no one solution. I have successfully set up a certificate for and [removef]. After that I installed gitlab on my server which is accessable under the subdomain . I tried to expand the certificate for this subdomain but get the error
DNS problem: SERVFAIL looking up A for …

I did some troubleshooting using dig, nslookup and checked various dns propagation checkers online and it seems more or less fine (3 failures on the online propagation check but they show failed also for the domains that are working fine).

I’m not too familiar with DNS so I hope someone can run some more extensive tests and let me know what is wrong. My registrar and DNS hoster is namecheap.

Thanks in advance,
Uli


#2

Your DNS is failing from a number of locations - not just for the subdomain, but for kiot.eu as well. Your DNS provider (Namecheap) might be having an outage or might be under a localized DDoS attack that’s causing requests from some locations (or for certain routes) to fail.

This is unlikely to be something on your end. I would recommend contacting Namecheap’s support - maybe include the results of something like dnschecker.org - or just waiting a couple of hours. If they’re unable to resolve this issue, switching to a different DNS provider would be an option - CloudFlare would be a free option, many sites also use Amazon’s Route53.


#3

Ok so it turns out that DNSSEC wasnt configured properly anymore after switching registrar. Namecheap fixed it and everything is working as expected.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.