Disable crontab


#1

Dear Let’s Encrypt community,

I’ve created my own cronjob for renewal for a simular case as an older ticket (see bottom).
TS tells he disabled the delivered crontab. I would like to know how I can do this as well.

@dandelionred told that you should not modify /etc/cron.d/certbot but certbot.service instead.
I assume he means /lib/systemd/system/certbot.service.

How do I disable crons using this file?
I’m running a Ubuntu 18.04 machine.

Content of /lib/systemd/system/certbot.service

[Unit]
Description=Certbot
Documentation=file:///usr/share/doc/python-certbot-doc/html/index.html
Documentation=https://letsencrypt.readthedocs.io/en/latest/
[Service]
Type=oneshot
ExecStart=/usr/bin/certbot -q renew
PrivateTmp=true

Older ticket by @jeffd :


#2

It’s probably not cron - it’s probably a systemd timer. The pesky things are
really sneaky.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.