DefaultCentralSslPfxPassword Problem

#1

Hi everyone,

First of allThanks to you for your great tool. My web site is HTTPS up and running Fine.

My system :

  • Windows Server 2012 R2
  • [INFO] A simple Windows ACMEv2 client (WACS)
  • [INFO] Software version 2.0.3.206 (RELEASE)
  • [INFO] IIS version 8.5
  • [INFO] Please report issues at https://github.com/PKISharp/win-acme

I use WACS which created theses files :

Inside MYID.renewal.json :

“Id”: MYID",
“LastFriendlyName”: “[IISSite] Default Web Site”,
“PfxPasswordProtected”: “enc-***************************************==”,
“TargetPluginOptions”:

Settings:

in my SETTINGS.CONFIG in WACS folder, i tried adding my password in the VALUE section of :
<setting name=“DefaultCentralSslPassword” serializeAs=“String”>
<value>MYPASSWORD</value>
</setting>
<setting name=“DefaultCentralSslPfxPassword” serializeAs=“String”>
<value>MYPASSWORD</value>
</setting>

My Issue:

My problem is that I need to use the PFXPasswordProtected, but in my application when , I call the PFX file using my password, it displays "The specified network password is not correct. ".

Tools to acess PFX: ASP PAGE :

Commands :
Set oEncrypt = Server.CreateObject(“Persits.CryptoManager”)
Set oStore = oEncrypt.OpenStoreFromPFX(“C:\ProgramData\win-acme\acme-v02.api.letsencrypt.org\Certificates\MY-ID.pfx”, “MYPASSWORD”)

Error message:

Persits.CryptoManager.1 error ‘800a0064’
The specified network password is not correct.

Question:

How to generate my own password to be embeded in the PFX file ?

Kind Regards,
Joaquim

#2

Tools to access PFX : Windows Certificate Import Wizard :

I get the same problem when I use Windows Certificate Import Wizard
After selecting the PFX file. I need to type the password, but I get a window “The password you entered is incorrect”.

#3

Hi @Joaquim1

perhaps you use non-ASCII characters. Or the file format of your settings.conf is wrong, so the password is saved as UTF-16 or something else.

#4

Thanks a lot JuergenAuer,

I checked all the file format and ANSI was ok. No UTF-8.

But I was doing it the wrong way.

I got the right answer from https://github.com/PKISharp/win-acme/issues/1071

The dirty way works !

I still have an issue with (Central Certificate Store (CCS). I also posted the error in https://github.com/PKISharp/win-acme/issues/1071

1 Like
#5

Ah, thanks, so there are two different passwords.

closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.