Default ssl conf isnt created

My ip is:
95.156.230.229 cause I want to migrate from vreecoaster.de to the IP
I ran this command:
I delete /etc/letsencrypt folder and replaced it by an old one, that was corrupt and yeah. How I delete or repair the files. I ran so much commands. :frowning:

It produced this output:
-bash: /usr/bin/certbot: No such file or directory

My web server is (include version):
Apache 2.38.2 Deb
The operating system my web server runs on is (include version):
Debian 10 Backports

I can login to a root shell on my machine (yes or no, or I don't know):
yes
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
no
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

If this is a new server without certbot, you'll need to install it first. If certbot isn't installed, it doesn't matter what the contents of /etc/letsencrypt is. Note: the certbot programs location is not inside /etc/letsencrypt.

Please see the instructions on:

1 Like

I was on this link. I've finished setup, then I changed the /etc/letsencrypt folder, then nothing worked and I read posts how to delete certbot completely and reinstall it new. But yeah the reinstall doesnt go normal.

What doesn't work when reinstalling certbot?

1 Like

-bash: /usr/bin/certbot: No such file or directory
I think cause this folder doesnt get created

That's an error from after the attempt to reinstall certbot. If the reinstall wasn't succesful, it's understandable the next command will fail too. I'd like to see what's going wrong during the reinstall of certbot. Perhaps it's just as simple as a missing symbolic link to the certbot program inside /snap/ somewhere.

You might try to run whereis certbot to see if it can find a location. If that doesn't give any proper result, I'd like to see the commands you ran to reinstall certbot and all the corresponding outputs.

image

Those are not (re)installation commands. All those commands are to RUN certbot. But if certbot isn't (re)installed, those commands won't work.

Please go back to Certbot - Debianbuster Apache and start from the top in stead of trying somewhere down the road.

Also, I notice the whereis command now too (missed that just now).. Which is strange. Apart from the above (about running the instructions from the top), I'm curious about what the output of ls -l /usr/bin/certbot might be.

image

OK, great, thanks. So the snap seems to be installed, but /usr/bin/certbot already exists. Perhaps it's pointing to some incorrect location? Could you run the ls -l /usr/bin/certbot command and see where it points to?

1 Like

lrwxrwxrwx 1 root root 17 Feb 4 21:13 /usr/bin/certbot -> /snap/bin/certbot

What the... I don't understand that.. :astonished:

Does running /snap/bin/certbot directly work perhaps?

1 Like

euhm what? I only want that the command "certbot" work. How I test that location?

I understand that, but for some reason, the symbolic link /usr/bin/certbot, which is used if you "just" run certbot seems to be malfunctioning (I don't know why). It should be possible to just type /snap/bin/certbot on the command line to at least check if certbot works or not.

image

Same results as the symbolic link.. Makes sense. However, I don't know why! I must confess I'm out of ideas, so let's call in the cavalry:

@certbot-devs I'm having trouble understanding this unability of the certbot snap to actually run at all. Can you help @crafter2345 ?

/snap/bin/certbot should, in turn, be a symlink to /usr/bin/snap.

ls -l /snap/bin/certbot
ls -l /usr/bin/snap
file /usr/bin/snap
uname -a
2 Likes

image
I need teccio.de and discord.vreecoaster.de in a different certificate

Are those hostnames running on that server? I.e., the same server as where you're running certbot?

1 Like

I fixed the problem by not doing it via snap but with apt install certbot and then a domain for each certificate individually.