Curl: (7) Failed to connect to port 443: Connection refused

Changed that for both :80 and :443

The TLS section should look a lot more like:
[feel free to modify/add/remove anything as needed - this should be a good starting point]

<VirtualHost *:443>
 ServerName www.apersonalvideo.com
 ServerAlias apersonalvideo.com
 DocumentRoot /var/www/html/
 SSLProtocol +TLSv1.2
 ProtocolsHonorOrder On
 Protocols h2 http/1.1
 SSLEngine On
 SSLCertificateFile      /etc/letsencrypt/live/apersonalvideo.com/fullchain.pem
 SSLCertificateKeyFile   /etc/letsencrypt/live/apersonalvideo.com/privkey.pem
 SSLCipherSuite EECDH+ECDSA:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-SHA256:DHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA:!3DES:!aNULL:!eNULL:!RC4
</VirtualHost>

And you need to update DNS:
Name: apersonalvideo.com
Address: 52.9.144.44

Name: www.apersonalvideo.com
*** UnKnown can’t find www.apersonalvideo.com: Non-existent domain

And when you get around to it, please explain that to me - I don’t understand what you mean.

Do I need to change the Virtual host section for :80?

Does it already work?
If “yes”, then leave it alone.

this can be removed - there is no cert for “localhost”:

I replaced:
<VirtualHost *:443>
ServerName localhost
DocumentRoot /var/www/html/
</VirtualHost>
With what you provided.

It is still not working.

You are confusing me…
Please show the current output of:
apachectl -S

apachectl -S

AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/httpd/conf/httpd.conf:356

AH00526: Syntax error on line 378 of /etc/httpd/conf/httpd.conf:

Invalid command ‘SSLProtocol’, perhaps misspelled or defined by a module not included in the server configuration

Most likely, your config is missing:
LoadModule ssl_module modules/mod_ssl.so

apachectl -S

httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Cannot load modules/mod_ssl.so into server: /etc/httpd/modules/mod_ssl.so: cannot open shared object file: No such file or directory

Try instead:
sudo a2enmod ssl

sudo: a2enmod: command not found

Then your apache version may be a bit “old”.
You should probably update it or check on Apache forums for HOW TO enable SSL/TLS for your specific version.

Try:
apache2 -version
httpd -version

httpd -v

Server version: Apache/2.4.41 (Amazon)

Looks current according to https://httpd.apache.org/download.cgi

Well then search: “HOW TO enable TLS on Amazon Apache2/2.4.41”

Unfortunately, this is an LE forum and your cert is already current/up-to-date.

I did try…
Sadly, I don’t use Amazon.

One last thing: We may have missed adding a LISTEN 443 statement.

Right below that add:
Listen 0.0.0.0:443

and see: https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/SSL-on-amazon-linux-ami.html

Thank you for your help.

I am still having a problem with:
Cannot load modules/mod_ssl.so into server: /etc/httpd/modules/mod_ssl.so: cannot open shared object file: No such file or directory

Not your problem, so I will take it from here.

As for the comment about software testing, have you seen any other initial posts with as much documented?