Create LE certificate


#1

In the past I created an LE certificate by using the command:
letsencrypt --apache --agree-tos --email my-email@domain.com -d my.domain.com
and set the option to use Secret

Now I get an error:
Client does not support any combination of challenges that will satisfy the CA.

I started on my empty VPS using commands as:
apt-get install letsencrypt python-letsencrypt-apache

Can you tell me what I am doing wrong?

Regards,
Guido van Harten


#2

Please review Solution: Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA

A fix has been shipped, but it may not have arrived in your operating system’s repositories yet.

In such a case, you may be able to use certbot-auto instead, which will give you the latest version, or use one of the workarounds as detailed in the above thread.


#3

Thanks for your reply.
I tried using certbot-auto. Maybe I am doing something incorrect… It doesn’t help me :frowning:

You wrote “A fix is shipped”… Can I force that fix to arrive it in my OS’s repository?

Regards,
Guido


#4

Can you show us what happened when you tried to use certbot-auto?


#5

In the meanwhile I reconfigured my VPS, so I can not show you what happened in the past hours :frowning:
After reconfiguring the VPS I entered the following commands:
apt-get -y update && apt-get -y upgrade
add-apt-repository ppa:certbot/certbot
apt-get install -y apache2 libapache2-mod-php7.0 php7.0-gd php7.0-json php7.0-mysql php7.0-curl php7.0-mbstring php7.0-intl php7.0-mcrypt php-imagick php7.0-xml php7.0-zip mysql-server php-mysql letsencrypt python-letsencrypt-apache redis-server php-redis python-certbot-apache

The system responds:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python-certbot-apache : Breaks: python-letsencrypt-apache but 0.4.1-1 is to be installed
python-letsencrypt-apache : Depends: python-letsencrypt but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

What am I doing wrong or what can I do to solve these problems?

Regards,
Guido


#6

Don’t try to install both the letsencrypt and certbot packages. They are direct substitutes for each other.

If you are using the PPA, then it’s just apt-get update && apt-get install python-certbot-apache and do not install letsencrypt or python-letsencrypt-*.


#7

I tried it again, but still I got errors.
After installing the needed packages and installing Nextcloud I tried to create the LE certificate.using the command
certbot --authenticator standalone --installer apache2 -d my.domain.com --pre-hook “service apache2 stop” --post-hook "service apache2 start"
But I get the error:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
The requested apache2 plugin does not appear to be installed
Which package do I have to install? I think python-letsencrypt-apache, but you wrote that I should not try both the letsencrypt an certbot packages.

Can you help me?

Regards,
Guido


#8

The --installer name is apache instead of apache2.


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.