Configuring iptables to Allow HTTPS Connections on Port 443


#1

I have describe my issue here http://stackoverflow.com/questions/43871311/open-443-port-for-ssl
I am unable to use SSL when iptables is active, Please check above thread for iptables config.

Can someone tell me what is wrong? Thanks


#2

You have used -A but I believe you might want to use -I to make sure you are not inserting your “allow” rules after any reject/drop which would match earlier (like the one quite a few packets hit according to what you have listed there).

NB: You might also want to try ufw (for CentOS should be available from EPEL) to make it a bit “easier” working with firewall rules. Keep in mind though that if you’re on VPS, then trying to run it in OpenVZ environment is not recommended :slight_smile: In KVM it works fine.


#3

Hi @Dshah,

I think your question could be insteresting but what is wrong is to post something not related at all with Let’s Encrypt, the clients used to get the certificates… blablabla but a problem with your firewall rules… ok, it is related to SSL… ok, go ahead, but you should take the time to copy the same you wrote on stackoverflow here. Putting a link with the question and the details to another site is not very polite.

I hope someone of this community (or the other one) could help you to solve your issue… anyway, I think @leader gave you a good advice already.

Cheers,
sahsanu


#4

I knew I was doing something stupid since I am setting this server up, Thank you for your kind support @leader , -I flag did the trick. I will definitely check ufw as iptables is a bit confusing subject for me right now.
@sahsanu , Thank you for the taking time to write all that I will take into consideration next time. Have a nice day/eve

Thanks again.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.