[CLOSED] I can't renew or fetch a new cert for my domain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: mail.basicallygaming.net

I ran this command: certbot renew, certbot certonly; mail.basicallygaming.net

It produced this output:

Processing /etc/letsencrypt/renewal/mail.basicallygaming.net.conf
Cert is due for renewal, auto-renewing...
Renewing an existing certificate
Performing the following challenges:
tls-sni-01 challenge for mail.basicallygaming.net
2017/09/17 11:59:12 [notice] 1510#1510: signal process started
2017/09/17 11:59:12 [error] 1510#1510: invalid PID number "" in "/run/nginx.pid"
Waiting for verification...
Cleaning up challenges
2017/09/17 11:59:17 [notice] 1530#1530: signal process started
2017/09/17 11:59:20 [notice] 1542#1542: signal process started

There were too many requests of a given type :: Error creating new cert :: too many certificates already issued for exact set of domains: mail.basicallygaming.net

My web server is (include version): nginx 1.13.4

The operating system my web server runs on is (include version): Arch Linux, 4.13.0-1-hardened

My hosting provider, if applicable, is: OVH VPS

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

Certbot kept outputting the log pasted above when I tried to renew my cert, but didn’t actually renew the certificate - then when I tried to remove the local files and fetch it from scratch it gave me that error and now I’m stuck without a cert (all certs for that address are currently revoked afaik).

After some trial and error, I’ve managed to restore the cert using one of the ones in archive/ along with a configuration file I made myself based on one of my other certs. It was a bit of an annoyance but it’s all fine now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.