[ CLOSED ] DNS problem: networking error looking up A record


#1

Hello! First let me say thanks to the letsencrypt community for creating such a wonderful way to acquire HTTPs!

I just had a slight issue using cerbot that I was curious if someone could assist me with. When running

cerbot --apache

I select the domains I want HTTPS added too, however certbot gives the following error:
Failed authorization procedure. jira.metamesh.org (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: networking error looking up A for jira.metamesh.org

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: jira.metamesh.org
   Type:   connection
   Detail: DNS problem: networking error looking up A for
   jira.metamesh.org

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.

I’m aware that this issue has been posted on the forums before, but in each case it was either a firewall issue or DNS issue. I can say with absolute 100% certainty that the issue is not with my server, nor my DNS. My A record for “jira.metamesh.org” is definitely pointing too our IP, 96.89.42.101

I’m honestly confused, as I’ve installed two certificates before this site on the same exact server with no trouble. Any help would be greatly appreciated!!

EDIT
It seems all users are having this problem at this time. As someone else suggested, using the “–staging” option with certbot solved the issue for me.


#2

Justin,

Thanks for the report!

There was an issue that has been resolved. It should be noted that the --staging option tests against the Let’s Encrypt staging CA and issues a certificate that is not trusted in browsers. It is a great way to test to make sure it is not a client issue on your side but an issue with the Let’s Encrypt service.

You should now run certbot without the --staging option to obtain a valid certificate from the trusted CA.


#3

Just a “me too” basically:

 + Responding to challenge for lucke.cba.si...
ERROR: Challenge is invalid! (returned: invalid) (result: {
  "type": "http-01",
  "status": "invalid",
  "error": {
    "type": "urn:acme:error:connection",
    "detail": "DNS problem: networking error looking up A for lucke.cba.si",
    "status": 400
  },

DNS looks good:

$ host lucke.cba.si 8.8.8.8
Using domain server:
Name: 8.8.8.8
Address: 8.8.8.8#53
Aliases:

lucke.cba.si is an alias for us.dev.cba.si.
us.dev.cba.si has address 170.130.139.8

$ host lucke.cba.si 208.67.222.222
Using domain server:
Name: 208.67.222.222
Address: 208.67.222.222#53
Aliases:

lucke.cba.si is an alias for us.dev.cba.si.
us.dev.cba.si has address 170.130.139.8

HTTPd also looks good:

$ curl -i http://lucke.cba.si/.well-known/acme-challenge/foo
HTTP/1.1 200 OK
Content-Type: application/octet-stream
Accept-Ranges: bytes
Content-Length: 0
Date: Sun, 17 Jul 2016 10:51:37 GMT
Server: lighttpd/1.4.31

Is there a DNS issue at letsencrypt.org?


#4

I’ve tried again now, and it works.


#5

Having this problem right now as well, it is broken again?


#6

I am also having issues with this right now. Seems the problem has popped up again.


#7

Hopping on this bandwagon. I also have DNS Resolution error running the same cron job that has been running successfully in the past.


#8

Actually, Pulling the most recent from Github fixed the issue.


#9

I’m currently experiencing this issue with simp_le.

EDIT: it fixed itself


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.