Changing domains

I search around this community and read all articles related to this but all all the info are spread and didn’t help.

I want to change alphafashionstyle.com with pulamea.tk. How can I do it?

My domain is: pulamea.tk

I ran this command: certbot certonly --cert-name pulamea.tk -d alphafashionstyle.com

It produced this output: Nothing changed

The operating system my web server runs on is (include version): Ubuntu 20.04 LTS

My hosting provider, if applicable, is: Google

I can login to a root shell on my machine (yes or no, or I don’t know): YES

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): NO only SSH

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.40.0

So you’ve already got a certificate for alphafasionstyle.com, right? And you want to change it to pulamea.tk, correct?

This command says: "get me a certificate for alphafasionstyle.com and call the certificate pulamea.tk without including the hostname pulamea.tk in the certificate itself.

You have to add the hostname you require with the -d option.

Thank you for your reply Osiris, so what is the right command to change that?

I already told you. 

I included -d in my command as you can see above.

Yes, but as I understand it (you didn’t confirm nor deny my assumption…) you used it in the wrong order.

What is the correct order and the correct command then?

Put the hostname you want in the certificate after the -d option.

I.e.: certbot --cert-name nameofcertificate -d hostnameyouwantincertificate

So the “nameofcertificate” is the existent certificate right?

Or another. You can have multiple certificates at the same time.

So to change the existent alphafashionstyle.com with pulamea.tk I run
certbot --cert-name alphafashionstyle.com -d pulamea.tk ?

That’s correct. When you run that command, you won’t have a certificate for the hostname alphafashionstyle.com any longer, because it will be overwritten by the new certificate for pulamea.tk.

2020-06-07 16:12:21,790:ERROR:certbot.log:An unexpected error occurred:
2020-06-07 16:12:21,791:ERROR:certbot.log:There were too many requests of a given type :: Error creating new>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.