Change base domain name for Lets Encrypt SSL certificate

I have used Let’s Encrypt to allow me to set up SSL/HTTPS on my server.

The issue is that I run a number of sub-domains too, which I included on the initial install, but looking back now - the certificate details show that it was issued to one of my sub-domains.

I’m wanting to change this to my base domain, but I’m just not sure how to do this.

I have tried running letsencrypt-auto --apache -d -d -d

This went through the process but did not change anything, as the certs are already issued.

How can I change the certificates now, or reissue them so that they are issued to my base domain?

Is your “base domain” included in the list of domains that the certificate is valid for ( and it’s just that the “base domain” isn’t the “common name” on the certificate ? (if so this is a known bug on the order of domain names on certificates in the current release of the code) or is this a different issue ( that your “base domain” is not included or something ).

My base domain is included and you’re correct - the “base domain” just isn’t the “common name”.

From my understanding Let’s Encrypt picked up the first domain name used as the common name and so by using your base domain first you could get around this - hence why I was trying to rerun the installation of the certificate.

As @serverco mentioned, this is a known bug in 0.5.0. This post has more details:

You should be able to re-issue the certificate easily with the correct CN once 0.6.0 has been released.

1 Like

Any idea when that will be? It's already WAY overdue!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.