Challenge failed for domain

I’m unable to install my cert and get the errors below.
firstly,i run the command

certbot certonly --standalone --agree-tos -n -d www.example.com -d example.com -m example@mail.com

but i get following error

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
Account registered.
Requesting a certificate for www.example.com and example.com
Performing the following challenges:
http-01 challenge for example.com
http-01 challenge for www.example.com
Waiting for verification...
Challenge failed for domain www.example.com
http-01 challenge for www.example.com
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: www.example.com
   Type:   dns
   Detail: During secondary validation: DNS problem: networking error
   looking up A for www.example; DNS problem:
   networking error looking up AAAA for
   www.example.com
1 Like

Welcome @frank2

It is difficult to help with such problems without knowing the actual DNS names

But, if the error only related to your www subdomain and not your apex name then my first guess is that you don't have an A and/or AAAA DNS record for the subdomain

Some tools you might use to diagnose the problem yourself are:
unboundtest.com
dnsviz.net

4 Likes

thank you

2 Likes

I wonder if I'm misinterpreting "secondary" in this context ...
But it seems (to me) that at least some of the DNS systems may have had a proper reply for the "www" name.
I would check to confirm that all authoritative DNS servers have the exact same information.

4 Likes

thank you,the isuue has solved

3 Likes