Challenge failed for domain


My local server had been disabled for some time, while I received an email recently that my certificate will expire. I tried to renew it manually, but it fails. I guess something is totally wrong as directory ".well-known/" was not present in my web root. I created the file "/.well-known/acme-challenge/test" as per another issue in the community, but it did not help.
I guess I need to cleanup everything and start from scratch. Could you please guide me on this?

My domain is:

I ran this command:
sudo certbot renew --dry-run

Tried also "sudo certbot --nginx -d" with the same result.

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log

Processing /etc/letsencrypt/renewal/

Cert is due for renewal, auto-renewing...
Plugins selected: Authenticator nginx, Installer nginx
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for
Waiting for verification...
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Attempting to renew cert ( from /etc/letsencrypt/renewal/ produced an unexpected error: Some challenges have failed.. Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/ (failure)

** DRY RUN: simulating 'certbot renew' close to cert expiry
** (The test certificates below have not been saved.)

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/ (failure)
** DRY RUN: simulating 'certbot renew' close to cert expiry
** (The test certificates above have not been saved.)

1 renew failure(s), 0 parse failure(s)


  • The following errors were reported by the server:

    Type: connection
    Detail: Fetching
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you're using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):
nginx/1.18.0 (Ubuntu)

The operating system my web server runs on is (include version):
Ubuntu 20.04.1 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 0.40.0

1 Like

Hi @essenov


is no answer. A working port 80 is required.

Works http internal?


from that machine? That's the first step.

If that works, it's a firewall / router problem.

1 Like

Hi Juergen,

Thank you for the quick reply.
Here is what I got from curl:


301 Moved Permanently

301 Moved Permanently

nginx/1.18.0 (Ubuntu)

I commented the following line in the nginx conf

return 301 https://$server_name:443$request_uri;

and added
location /.well-known/acme-challenge { }

and reloaded nginx service, but certbot still fails with the same error.

1 Like

That's expected, please read my answer.

1 Like

I can access my http from my mobile phone carrier. Can't you access ?

1 Like

I can't, same with online tools - see

Domainname Http-Status redirect Sec. G
ā€¢ -14 10.003 T
Timeout - The operation has timed out
ā€¢ -14 10.033 T
Timeout - The operation has timed out
ā€¢ -14 10.010 T
Timeout - The operation has timed out

If online tools can't see your domain, Letsencrypt can't validate your domain via http validation.

1 Like

I agree with @JuergenAuer
Please note:

80/tcp  filtered http
443/tcp filtered https

Something in the mix is blocking access to your stuff.

Thanks a lot Juergen.

It appeared the ISP has reset (deleted) the port forwarding from their router.
I have now managed to renew the certificates.

Happy Holidays,

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.