Certification is not working in Firefox. Your connection is not secure


#1

Hi,

We have problems loading our web page with Firefox using our LE certificate.
How can I resolve this problem, please ?

Info:

Server: Ubuntu 16.04
Web Server: Apache 2.4.18
Using Certbot.

Error shown in Firefox:

www.checkingjob.com uses an invalid security certificate.
The certificate is only valid for checkingjob.com
Error code: SSL_ERROR_BAD_CERT_DOMAIN

Firefox:

checkingjob.com -> https://checkingjob.com ok
checkingjob.es -> https://checkingjob.com ok
www.checkingjob.com -> your connection is not secure <-- Problem
www.checkingjob.es -> https://checkingjob.com ok

Chrome:

checkingjob.com -> https://checkingjob.com ok
checkingjob.es -> https://checkingjob.com ok
www.checkingjob.com -> https://checkingjob.com ok <-- It works !!
www.checkingjob.es -> https://checkingjob.com ok

Certificate Name: checkingjob.com
Domains: checkingjob.com
Expiry Date: 2017-11-12 21:25:00+00:00 (VALID: 46 days)

–EOF


#2

There’s your problem. You obtained a certificate for checkingjob.com; that does not include www.checkingjob.com. Fix your certificate.


#3

Hi Danb35,

Yes, you’re right. How can I fix my certificate …?

It must be a silly thing to solve it, but i cannot find the fix for our certificate.

Would you mind to show me the way, please ?

Thanks


#4

However you created the cert in the first place, you’ll need to re-create it including both names. I can’t give you more detail, because I have no idea how you originally created it.


#5

Since we don’t know the exact commands you used, it’s difficult to say exactly what to do. If you can provide the command you used to get the certificate, we can suggest an updated command that will work for both names and that should update the directories to use a new certificate with the additional name.


#6

He said he used certbot. :slight_smile:

If you just ran certbot and followed the prompts, do that again and it should offer to do www for you.

If you did it all on the command line, you can run:

certbot --expand --apache -d checkingjob.com,www.checkingjob.com

Replace --apache with whatever plugin options you used before, if different (maybe nginx or webroot).


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.