Certificate Showing as localhost.localdomain?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:mk1.contrado.cloud

My web server is (include version): CentOS 7

The operating system my web server runs on is (include version): CentOS 7

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.30.0

This is a playground VM, so I'm not too bothered about it. Just can't quite figure out why when I load the website up it over https it is showing up as a certificate for localhost.localdomain.

It's running Apache/httpd web server

There is nothing on this server other than an index.html file

I've set up Let's Encrypt countless times, but never seen this one before.

I've opened up on the CentOS 7 firewall both HTTP and HTTPS

I have a feeling that it's likely due to a few incorrect configs while playing with this VM that something was done in the wrong order and things have got tied in a bit of a knot.

Not sure what the best way of debugging this one is to get it working.

Certbot was installed via snap.

I'd prefer not to bin off the VM and start from scratch - even though I know this would fix the problem. I'd like to debug it to get it working.

What does sudo certbot certificates show? Please use 3 backticks before and after
output of: sudo certbot certificates
(omit sudo if not needed)


Asked and answered - LOL

Apache is likely up to some mischief.
Please show the output of:
apachectl -t -D DUMP_VHOSTS

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Found the following certs:
  Certificate Name: mk1.contrado.cloud
    Serial Number: 42936657b96f29a40066e7c75016c2e63e5
    Key Type: RSA
    Domains: mk1.contrado.cloud
    Expiry Date: 2022-12-15 13:45:30+00:00 (VALID: 89 days)
    Certificate Path: /etc/letsencrypt/live/mk1.contrado.cloud/fullchain.pem
    Private Key Path: /etc/letsencrypt/live/mk1.contrado.cloud/privkey.pem
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

httpd -t -D DUMP_VHOSTS

[root@localhost conf]# httpd -t -D DUMP_VHOSTS
[Fri Sep 16 21:04:49.233748 2022] [core:error] [pid 8667] (EAI 2)Name or service not known: AH00547: Could not resolve host name *.80 -- ignoring!
[Fri Sep 16 21:04:49.234489 2022] [core:error] [pid 8667] (EAI 2)Name or service not known: AH00547: Could not resolve host name *.80 -- ignoring!
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using localhost.localdomain. Set the 'ServerName' directive globally to suppress this message
VirtualHost configuration:
*:443                  localhost.localdomain (/etc/httpd/conf.d/ssl.conf:56)

This is line 56;

## SSL Virtual Host Context

<VirtualHost _default_:443>
### ^^^ is line 56

# General setup for the virtual host, inherited from global configuration
#DocumentRoot "/var/www/html"
#ServerName www.example.com:443

I have a feeling the root cause of this problem is that I ran certbot while only HTTP traffic was open on firewall-cmd, so it got a bit stuck and messed something up along the way. Then I opened HTTPS on firewall-cmd, but that didn't solve the problem.

I have certbot working fine on another VM I've been playing with which is the identical setup helloworld.contrado.cloud.

One problem I see right now is nothing can connect to your domain with either HTTP or HTTPS. Not from SSL Labs, my favorite SSL Test checker site, and not my own test server. It looks like you might have a firewall blocking ports 80 and 443.

You got certs just fine about 5 hours ago. In fact, you've gotten your weekly limit of 5 already today. See here

Your ssl.conf does not look complete. Perhaps by running certbot "too early" before you had a properly working HTTP VirtualHost.

But, what most concerns me are those core:error messages in response to your httpd -t command. And, there is no viable port 80 VirtualHost shown (probably because of that).

That is the first thing to resolve. I've never seen that error before so don't know what to suggest other than reviewing your httpd.conf file line by line.

Maybe sudo systemctl status httpd would show more info?


Good spot @MikeMcQ

The VMs are hosted behind the same firewall I'm typing from so I hadn't spotted that they weren't publicly accessible as they are accessible to me due to NAT Reflection on the pfSense firewall. I've updated the firewall so that the helloworld.contrado.cloud one is now publicly accessible. I've no idea what is going on with the mk1.contrado.cloud one right now.

I think I'm going to bin off these VMs and start from scratch. They have had a few iterations of playing around so far so it feels like something has got a bit confused under the hood. It's sometimes more effort to debug these things than it is to just bin the VMs and re-build.

Possibly not. @MikeMcQ looked up your domain and thinks the certs issued fine.

Certbot does two things:

  • It's an ACME client
  • It configures Apache and Nginx

The ACME stuff that Certbot does is rock-solid and best-in-class. The webserver configuration is "best effort" and always needing improvement. It handles simple configuration files very well, but it can't understand the more esoteric configurations, and only improves as people surface new edge cases as bug reports. IIRC, the overwhelming majority of Certbot development in the past 5 years has been dedicated to improving the webserver configuration.

Before trashing everything, just check the contents of /etc/letsencrypt to see if you have the certs. If you do, just try to edit the apache configurations - and post them here if you get lost. There was probably a line or two that wasn't compatible with Certbot.


Yeah the certs are on the VMs in /etc/letsencrypt/live/mk1.contrado.cloud

Here is the file for '/etc/httpd/conf.d/mk1.contrado.cloud.conf'

<VirtualHost *.80>
        ServerName mk1.contrado.cloud
        DocumentRoot /var/www/mk1.contrado.cloud/public_html

        ErrorLog /etc/httpd/logs/mk1.contrado.cloud-error.log
        CustomLog /etc/httpd/logs/mk1.contrado.cloud-access.log combined
RewriteEngine on
RewriteCond %{SERVER_NAME} =mk1.contrado.cloud
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

Here is the file for '/etc/httpd/conf.d/mk1.contrado.cloud-le-ssl.conf'

<IfModule mod_ssl.c>
<VirtualHost *:443>
        ServerName mk1.contrado.cloud
        DocumentRoot /var/www/mk1.contrado.cloud/public_html

        ErrorLog /etc/httpd/logs/mk1.contrado.cloud-error.log
        CustomLog /etc/httpd/logs/mk1.contrado.cloud-access.log combined

Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateFile /etc/letsencrypt/live/mk1.contrado.cloud/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/mk1.contrado.cloud/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/mk1.contrado.cloud/chain.pem

Interestingly in the above file, I noticed earlier that the line was somehow configured as;

<VirtualHost *.80:443>

So I tweaked that earlier to correct that.

I've even tried uninstalling httpd (via yum) then re-installing. Interestingly when I did this, the files remained which I wasn't expecting. Seems odd.

So what does that command look like now?

Because this still needs work :slight_smile:
<VirtualHost *.80>

1 Like
[Fri Sep 16 22:54:35.205023 2022] [core:error] [pid 10395] (EAI 2)Name or service not known: AH00547: Could not resolve host name *.80 -- ignoring!
VirtualHost configuration:
*:443                  is a NameVirtualHost
         default server mk1.contrado.cloud (/etc/httpd/conf.d/mk1.contrado.cloud-le-ssl.conf:2)
         port 443 namevhost mk1.contrado.cloud (/etc/httpd/conf.d/mk1.contrado.cloud-le-ssl.conf:2)
         port 443 namevhost mk1.contrado.cloud (/etc/httpd/conf.d/ssl.conf:56)

yum does not guarantee that configuration files will be preserved or removed during a package uninstall.

other distros will preserve the config files by default, and only remove them on a "purge"


I've just tweaked a few settings, noticed that some of the IP routing from the firewall to the VMs got a bit corss-wired. Probably explains why I've been a tad confused why it wasn't working. Got that lined up now though so both are now accessible publicly and also certs are issuing correctly on both



Did you fix the duplicate port 443 config files in your latest httpd -t -D DUMP_VHOSTS ?


Interesting, good to know, thanks @jvanasco

Looks like yum works in a bit of a "meh.... who knows" kind of way.

Do you know if there is a way to force yum to remove the related files too? I'm just having a search online for this info as I don't know myself.

@MikeMcQ No, I'm not sure what is causing that. Here is the output from "cat /etc/httpd/conf.d/ssl.conf"

What is odd is the start/end of the element. Line 56 + final line. Seems strangely positioned.

I don't play with these configs often enough to easily spot what is normal and what isn't - so the answer is probably staring me right in the face and I'm just not seeing it.

# When we also provide SSL we have to listen to the
# the HTTPS port in addition.
Listen 443 https

##  SSL Global Context
##  All SSL configuration in this context applies both to
##  the main server and all SSL-enabled virtual hosts.

#   Pass Phrase Dialog:
#   Configure the pass phrase gathering process.
#   The filtering dialog program (`builtin' is a internal
#   terminal dialog) has to provide the pass phrase on stdout.
SSLPassPhraseDialog exec:/usr/libexec/httpd-ssl-pass-dialog

#   Inter-Process Session Cache:
#   Configure the SSL Session Cache: First the mechanism
#   to use and second the expiring timeout (in seconds).
SSLSessionCache         shmcb:/run/httpd/sslcache(512000)
SSLSessionCacheTimeout  300

#   Pseudo Random Number Generator (PRNG):
#   Configure one or more sources to seed the PRNG of the
#   SSL library. The seed data should be of good random quality.
#   WARNING! On some platforms /dev/random blocks if not enough entropy
#   is available. This means you then cannot use the /dev/random device
#   because it would lead to very long connection times (as long as
#   it requires to make more entropy available). But usually those
#   platforms additionally provide a /dev/urandom device which doesn't
#   block. So, if available, use this one instead. Read the mod_ssl User
#   Manual for more details.
SSLRandomSeed startup file:/dev/urandom  256
SSLRandomSeed connect builtin
#SSLRandomSeed startup file:/dev/random  512
#SSLRandomSeed connect file:/dev/random  512
#SSLRandomSeed connect file:/dev/urandom 512

# Use "SSLCryptoDevice" to enable any supported hardware
# accelerators. Use "openssl engine -v" to list supported
# engine names.  NOTE: If you enable an accelerator and the
# server does not start, consult the error logs and ensure
# your accelerator is functioning properly.
SSLCryptoDevice builtin
#SSLCryptoDevice ubsec

## SSL Virtual Host Context

<VirtualHost _default_:443>

# General setup for the virtual host, inherited from global configuration
#DocumentRoot "/var/www/html"
#ServerName www.example.com:443

# Use separate log files for the SSL virtual host; note that LogLevel
# is not inherited from httpd.conf.
ErrorLog logs/ssl_error_log
TransferLog logs/ssl_access_log
LogLevel warn

#   SSL Engine Switch:
#   Enable/Disable SSL for this virtual host.
SSLEngine on

#   SSL Protocol support:
# List the enable protocol levels with which clients will be able to
# connect.  Disable SSLv2 access by default:
SSLProtocol all -SSLv2 -SSLv3

#   SSL Cipher Suite:
#   List the ciphers that the client is permitted to negotiate.
#   See the mod_ssl documentation for a complete list.

#   Speed-optimized SSL Cipher configuration:
#   If speed is your main concern (on busy HTTPS servers e.g.),
#   you might want to force clients to specific, performance
#   optimized ciphers. In this case, prepend those ciphers
#   to the SSLCipherSuite list, and enable SSLHonorCipherOrder.
#   Caveat: by giving precedence to RC4-SHA and AES128-SHA
#   (as in the example below), most connections will no longer
#   have perfect forward secrecy - if the server's key is
#   compromised, captures of past or future traffic must be
#   considered compromised, too.
#SSLHonorCipherOrder on

#   Server Certificate:
# Point SSLCertificateFile at a PEM encoded certificate.  If
# the certificate is encrypted, then you will be prompted for a
# pass phrase.  Note that a kill -HUP will prompt again.  A new
# certificate can be generated using the genkey(1) command.
SSLCertificateFile /etc/pki/tls/certs/localhost.crt

#   Server Private Key:
#   If the key is not combined with the certificate, use this
#   directive to point at the key file.  Keep in mind that if
#   you've both a RSA and a DSA private key you can configure
#   both in parallel (to also allow the use of DSA ciphers, etc.)
SSLCertificateKeyFile /etc/pki/tls/private/localhost.key

#   Server Certificate Chain:
#   Point SSLCertificateChainFile at a file containing the
#   concatenation of PEM encoded CA certificates which form the
#   certificate chain for the server certificate. Alternatively
#   the referenced file can be the same as SSLCertificateFile
#   when the CA certificates are directly appended to the server
#   certificate for convinience.
#SSLCertificateChainFile /etc/pki/tls/certs/server-chain.crt

#   Certificate Authority (CA):
#   Set the CA certificate verification path where to find CA
#   certificates for client authentication or alternatively one
#   huge file containing all of them (file must be PEM encoded)
#SSLCACertificateFile /etc/pki/tls/certs/ca-bundle.crt

#   Client Authentication (Type):
#   Client certificate verification type and depth.  Types are
#   none, optional, require and optional_no_ca.  Depth is a
#   number which specifies how deeply to verify the certificate
#   issuer chain before deciding the certificate is not valid.
#SSLVerifyClient require
#SSLVerifyDepth  10

#   Access Control:
#   With SSLRequire you can do per-directory access control based
#   on arbitrary complex boolean expressions containing server
#   variable checks and other lookup directives.  The syntax is a
#   mixture between C and Perl.  See the mod_ssl documentation
#   for more details.
#<Location />
#SSLRequire (    %{SSL_CIPHER} !~ m/^(EXP|NULL)/ \
#            and %{SSL_CLIENT_S_DN_O} eq "Snake Oil, Ltd." \
#            and %{SSL_CLIENT_S_DN_OU} in {"Staff", "CA", "Dev"} \
#            and %{TIME_WDAY} >= 1 and %{TIME_WDAY} <= 5 \
#            and %{TIME_HOUR} >= 8 and %{TIME_HOUR} <= 20       ) \
#           or %{REMOTE_ADDR} =~ m/^192\.76\.162\.[0-9]+$/

#   SSL Engine Options:
#   Set various options for the SSL engine.
#   o FakeBasicAuth:
#     Translate the client X.509 into a Basic Authorisation.  This means that
#     the standard Auth/DBMAuth methods can be used for access control.  The
#     user name is the `one line' version of the client's X.509 certificate.
#     Note that no password is obtained from the user. Every entry in the user
#     file needs this password: `xxj31ZMTZzkVA'.
#   o ExportCertData:
#     This exports two additional environment variables: SSL_CLIENT_CERT and
#     SSL_SERVER_CERT. These contain the PEM-encoded certificates of the
#     server (always existing) and the client (only existing when client
#     authentication is used). This can be used to import the certificates
#     into CGI scripts.
#   o StdEnvVars:
#     This exports the standard SSL/TLS related `SSL_*' environment variables.
#     Per default this exportation is switched off for performance reasons,
#     because the extraction step is an expensive operation and is usually
#     useless for serving static content. So one usually enables the
#     exportation for CGI and SSI requests only.
#   o StrictRequire:
#     This denies access when "SSLRequireSSL" or "SSLRequire" applied even
#     under a "Satisfy any" situation, i.e. when it applies access is denied
#     and no other module can change it.
#   o OptRenegotiate:
#     This enables optimized SSL connection renegotiation handling when SSL
#     directives are used in per-directory context.
#SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
<Files ~ "\.(cgi|shtml|phtml|php3?)$">
    SSLOptions +StdEnvVars
<Directory "/var/www/cgi-bin">
    SSLOptions +StdEnvVars

#   SSL Protocol Adjustments:
#   The safe and default but still SSL/TLS standard compliant shutdown
#   approach is that mod_ssl sends the close notify alert but doesn't wait for
#   the close notify alert from client. When you need a different shutdown
#   approach you can use one of the following variables:
#   o ssl-unclean-shutdown:
#     This forces an unclean shutdown when the connection is closed, i.e. no
#     SSL close notify alert is send or allowed to received.  This violates
#     the SSL/TLS standard but is needed for some brain-dead browsers. Use
#     this when you receive I/O errors because of the standard approach where
#     mod_ssl sends the close notify alert.
#   o ssl-accurate-shutdown:
#     This forces an accurate shutdown when the connection is closed, i.e. a
#     SSL close notify alert is send and mod_ssl waits for the close notify
#     alert of the client. This is 100% SSL/TLS standard compliant, but in
#     practice often causes hanging connections with brain-dead browsers. Use
#     this only for browsers where you know that their SSL implementation
#     works correctly.
#   Notice: Most problems of broken clients are also related to the HTTP
#   keep-alive facility, so you usually additionally want to disable
#   keep-alive for those clients, too. Use variable "nokeepalive" for this.
#   Similarly, one has to force some clients to use HTTP/1.0 to workaround
#   their broken HTTP/1.1 implementation. Use variables "downgrade-1.0" and
#   "force-response-1.0" for this.
BrowserMatch "MSIE [2-5]" \
         nokeepalive ssl-unclean-shutdown \
         downgrade-1.0 force-response-1.0

#   Per-Server Logging:
#   The home of a custom SSL log file. Use this when you want a
#   compact non-error SSL logfile on a virtual host basis.
CustomLog logs/ssl_request_log \
          "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"


Probably because you don't have a ServerName and it's picking a value from elsewhere. You should uncomment that line and makeup a name that won't match (like _default or null or something).

Avoid proceeding until you get a clean DUMP_VHOSTS report. Note your VHost for port 80 is still not working. It does not redirect per your config. See post #12 for clue :slight_smile:


@MikeMcQ Which file needs editing? The ServerName exists in a lot of the files mentioned.