Certificate renewal failing

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:rds.walneyschool.org.uk

I ran this command:

It produced this output:

My web server is (include version): IIS

The operating system my web server runs on is (include version):Windows server 2012r2 standard

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): I dont know

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

I get the error "Validation of the required challenges did not complete successfully. Domainvalidation failed: rds.walneyschool.org.uk
Fetching http://rds.walneyscholl.org.uk/.well-known/acme-challenge/ Timeout during connect (Likely firewall problem) Bad Request urn:ietf:params:acme:error:connection
The Windows firewall is turned off, our fortigate allows all traffic to and from this server and ports 80 and 443 are open to http/https traffic. The service has worked for over 2 years but has suddenly stopped.

I can't connect to your server on port 80 nor port 443 from my laptop.

$ curl -vvv -m10 http://rds.walneyschool.org.uk
*   Trying 217.114.61.45:80...
* Connected to rds.walneyschool.org.uk (217.114.61.45) port 80 (#0)
> GET / HTTP/1.1
> Host: rds.walneyschool.org.uk
> User-Agent: curl/7.79.1
> Accept: */*
>
* Operation timed out after 10005 milliseconds with 0 bytes received
* Closing connection 0
curl: (28) Operation timed out after 10005 milliseconds with 0 bytes received
3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.