Certificate renewal error (Cloudflare DNS)

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
wacs.exe --source manual --host psychosoft.dk,*.psychosoft.dk --validation
cloudflare --cloudflareapitoken ******* --store centralssl --centralsslstore
"\SMB Storage\IIS Shared\Certificates" --pfxpassword *******

It produced this output:
Plugin Manual generated source psychosoft.dk with 2 identifiers
Plugin Single created 1 order
Renewing [Manual] psychosoft.dk
Cached order has status invalid, discarding
[.psychosoft.dk] Authorizing...
.psychosoft.dk] Authorizing using dns-01 validation (Cloudflare)
[.psychosoft.dk] Error preparing for challenge answer
.psychosoft.dk] Deactivating pending authorization
[psychosoft.dk] Deactivating pending authorization
Renewal for [Manual] psychosoft.dk failed, will retry on next run
Error preparing for challenge answer
No certificate generated

My web server is (include version):

The operating system my web server runs on is (include version):
Windows Server 2016 - Version 1607 (Build 14393.5989)

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
no, using WACS commandline

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
A simple Windows ACMEv2 client (WACS)
Software version (release, pluggable, standalone, 64-bit)

My setup has been running as a scheduled task for years and always working until the run on the 21/jun-23. Then it stopped working and generate the above error on every try.
Before that it has been running for 10 different sites without any issues. I have 18 days left on my certificates :scream:

I'd guess your cloudflare API token has a problem. Did you replace it recently?

If you don't get any further and updating win-acme doesn't help try the same with https://certifytheweb.com instead, that would rule out the software.


Continued to drill into the problem after creating this support ticket and found the answer.

To answer @webprofusion That was my first thought as well. But API token is good, have verified.

Problem if anyone else run into this. I'm using Chocolatey as package manager for WACS, so using latest version. But apparently the Cloudflare plugin isn't updated so after a manual download everything worked again! :+1:

Link to plugins for others in same situation:
Releases · win-acme/win-acme (github.com)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.