Certificate not renewing on a cloned vm

#1

I created a clone of a live centos install, which is still running and working correctly, but the renamed clone will not recertify.As far as I can tell I have amended everything that I should, and had my ports open both on the vm, and through the university firewall. Any advice would be great!

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: ctu-demo-clone.clinmed.gla.ac.uk

I ran this command: certbot-auto

It produced this output:Obtaining a new certificate
Performing the following challenges:
http-01 challenge for ctu-demo-clone.clinmed.gla.ac.uk
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. ctu-demo-clone.clinmed.gla.ac.uk (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://ctu-demo-clone.clinmed.gla.ac.uk/.well-known/acme-challenge/xRjpimWFqWzWY6uQu7yXkjTztX_4KZSx-tiPgeq4D6E: Timeout during connect (likely firewall problem)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: ctu-demo-clone.clinmed.gla.ac.uk
    Type: connection
    Detail: Fetching
    http://ctu-demo-clone.clinmed.gla.ac.uk/.well-known/acme-challenge/xRjpimWFqWzWY6uQu7yXkjTztX_4KZSx-tiPgeq4D6E:
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): httpd-2.4.6-88.el7.centos.x86_64

The operating system my web server runs on is (include version): CentOS Linux release 7.6.1810 (Core)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot 0.29.1

#2

Hi @Stephen_CTU

your server is invisible ( https://check-your-website.server-daten.de/?q=ctu-demo-clone.clinmed.gla.ac.uk ):

Domainname Http-Status redirect Sec. G
• http://ctu-demo-clone.clinmed.gla.ac.uk/
130.209.123.239 -14 10.026 T
Timeout - The operation has timed out
• https://ctu-demo-clone.clinmed.gla.ac.uk/
130.209.123.239 -14 10.030 T
Timeout - The operation has timed out
• http://ctu-demo-clone.clinmed.gla.ac.uk/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
130.209.123.239 -14 10.026 T
Timeout - The operation has timed out

Certbot creates a file under /.well-known/acme-challenge, Letsencrypt checks this file.

But then the answer should be http status 404 - not found.

Instead: Timeouts.

So recheck your firewall.

1 Like
#3

That’s interesting. I shall double check, and get back to my domain admin folks to see if they can explain, as they have assured me that they had opened it as I had asked. Thanks

#4

If they open the firewall, my tool should see a website with http status 200, 404, 401 or 500. All is better then a timeout.

I see, you have rechecked your domain. Same result, three timeouts.

#5

Excellent! I went back to the admins, and there was something that hadn’t been opened correctly at their end.
Open now.
New errors, but that’s for me to now investigate.
Thanks for the help!

1 Like
#6

But only your https, not your http - port.

I see, you have rechecked your domain ( https://check-your-website.server-daten.de/?q=ctu-demo-clone.clinmed.gla.ac.uk ).

http doesn’t work, but is required to use http-01 - validation.

Rechecked manual, same connect failure.

#7

Ah, I see. That might explain the new errors that I have. I’m fairly new to this type of thing, so fumbling about a bit. I shall ask the admins about the http port

closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.