Certificate issue with wrong cname. on renewal its remian same what to do?


#1

Please fill out the fields below so we can help you better.

My domain is:https://spot.domain.com/

I ran this command:letsencrypt/letsencrypt-auto certonly -d www.spot.domain.com -d spot.domain.com -w /var/www/spot.domain.com/

It produced this output:Congratulations! Your certificate and chain have been saved at
/etc/letsencrypt/live/spot.domain.com/fullchain.pem. Your
cert will expire on 2017-03-14. To obtain a new or tweaked version
of this certificate in the future, simply run letsencrypt-auto
again. To non-interactively renew all of your certificates, run
"letsencrypt-auto renew"

My operating system is (include version):Linux Debian 8

My web server is (include version):hetzner (Linux Debian 8)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):No

I have create certificate and i dont know its show wrong cname and i can’t change it or remove it i have remove all file fromm renew, archibe and live folder but still its showing same ssl . I have also renew SSL. below is error i got in mozilla firefox

www.spot.domain.com uses an invalid security certificate. The certificate is only valid for blog.domain.com (Error code: ssl_error_bad_cert_domain)


#2

The certificate installed on that site is for blog.mysecretcase.com and is only valid for that domain name

you need to generate a new certificate for www.spot.mysecretcase.com and spot.mysecretcase.com … but you say above you did that already.

Did you then change your host config to reflect the new certificates files locations and restart your web server?

Make sure you vhost config for the site is pointing to the correct certificates at: /etc/letsencrypt/live/spot.mysecretcase.com/


#3

Thanks Man. Its work. i dont why but i have tried before as well to add in virtuall host config file. now its work thanks for your help.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.