Certificate expired, how to renew on AWS lightsail

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: monva.co

I ran this command:

It produced this output:

My web server is (include version): ubuntu

The operating system my web server runs on is (include version): Wordpress / Amazon Lightsail

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know): Yes via AWS control panel SSH

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi @wiley72

checking your domain there is a wildcard certificate - https://check-your-website.server-daten.de/?q=monva.co

Issuer not before not after Domain names LE-Duplicate next LE
Let's Encrypt Authority X3 2019-08-06 2019-11-04 *.monva.co, monva.co
2 entries

How did you create that certificate? Do that again.

So I followed the steps, but get a “Another instance of Certbot is already running” message

I followed this


sudo certbot -d $DOMAIN -d $WILDCARD --manual --preferred-challenges dns certonly

Entered the new TXT Record

Received the following
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. monva.co (dns-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking
up TXT for _acme-challenge.monva.co


  • The following errors were reported by the server:

    Domain: monva.co
    Type: None
    Detail: DNS problem: NXDOMAIN looking up TXT for

Checking your domain you are doing something wrong - https://check-your-website.server-daten.de/?q=monva.co#txt

There is only one TXT entry visible. But your command has two domain names.

Your older check

has two values.

Certbot gives you two different values -> you have to create two different entries with the same domain name, but different values.

It can also provide just one. Have just solved it. Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.