Certificate error (expired) but certbot reports everything is ok

I've been using let's encrypt certificates without a problem for 3/4 months now and suddenly when I tried to access one of my domains I got a certificate error saying it was expired:

But when I run certbot on the host it comes up as if everything is ok! I even ran force-renew but it didn't fix it.

Can anyone help?

My domain is:
I ran this command:
cerbot certificates
It produced this output:

  Certificate Name: pb.govwise.biz
    Domains: pb.govwise.biz
    Expiry Date: 2022-04-19 20:00:05+00:00 (VALID: 89 days)
    Certificate Path: /etc/letsencrypt/live/pb.govwise.biz/fullchain.pem
    Private Key Path: /etc/letsencrypt/live/pb.govwise.biz/privkey.pem

My web server is (include version):
nginx/1.18.0 (Ubuntu)
The operating system my web server runs on is (include version):
Ubuntu 20.04.3 LTS
My hosting provider, if applicable, is:
Digital Ocean
I can login to a root shell on my machine (yes or no, or I don't know):
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 0.40.0

Fixed it by running:

certbot delete 

and choosing the affected domain and then creating a new certificate.

1 Like

Please confirm that you don't have more certs than you need:
certbot certificates

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.