Certificate cron auto-renew not working!


I have installed SSL certificates and configured a cron job to automatically renew the certificates prior to their expiration, but the certificates are not renewing.

FYI I am running WordPress Bitnami LAMP on Google compute engine with Apache/2.4.25 (Unix)

I created the cronjob by running sudo crontab -e

At first I used the following cron command, but it didn’t work:
26 1 * * * cd && ./certbot-auto renew -q && sudo /opt/bitnami/ctlscript.sh restart apache

Then, based on the response that I viewed on this forum, I tried a different auto-renew command:
26 1 * * * sudo /opt/bitnami/ctlscript.sh stop && ./certbot-auto renew --force-renew && sudo /opt/bitnami/ctlscript.sh start

However, neither of these cron jobs worked at renewing the certificates. Here is the output from var/log/syslog:
Jan 18 08:19:01 gardens-vm CRON[31461]: (root) CMD (sudo /opt/bitnami/ctlscript.sh stop && ./certbot-auto renew --force-renew && sudo /opt/bitnami/ctlscript.sh start)
Jan 18 08:19:01 gardens-vm CRON[31460]: (CRON) info (No MTA installed, discarding output)
Jan 18 08:19:35 gardens-vm collectd[428]: write_gcm: wg_transmit_unique_segment failed.
Jan 18 08:19:35 gardens-vm collectd[428]: write_gcm: wg_transmit_unique_segments failed. Flushing.

Any advice and/or recommendations would be appreciated!
Thanks :smiley:

A helpful first step would be to run the renewal command from manually, and show us what the output is :slight_smile: .

sudo /root/certbot-auto renew

(or wherever the certbot-auto file is).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.