Certbot ssl failed

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: http://matter.kai.com

I ran this command: certbot --nginx -d matter.kai.com

It produced this output: Certbot failed to authenticate some domains (authenticator: nginx). The Certificate Authority reported these problems:
Domain: matter.kai.com
Type: dns
Detail: DNS problem: NXDOMAIN looking up A for matter.kai.com - check that a DNS record exists f or this domain; DNS problem: NXDOMAIN looking up AAAA for matter.kai.com - check that a DNS record exists for this domain

Hint: The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx server and that it is accessible from the internet.

My web server is (include version):

The operating system my web server runs on is (include version): red hat 8.7

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 2.5.0

The nginx plug-in uses the HTTP Challenge method so requires an A and/or AAAA record in your DNS so that Let's Encrypt knows how to find your server to validate control of this domain name.

And, this says you don't have one. You use an A record for IPv4 and AAAA for IPv6. You don't need both but you need at least one.


can i check with you, as i am new to it and i created my dns through window server 2019(AD),
must the domain need to be from a website in order for it to work?

Using ICANN Lookup with kai.com as the input yields

And the name servers do not know about the domain name kai.com

$ nslookup kai.com F1G1NS1.DNSPOD.NET.
Server:         F1G1NS1.DNSPOD.NET.

** server can't find kai.com: NXDOMAIN
$ nslookup kai.com F1G1NS2.DNSPOD.NET.
Server:         F1G1NS2.DNSPOD.NET.

** server can't find kai.com: NXDOMAIN

Can i ask how to i make the server know of my domain?

Go to your Domain Registrar and update the DNS records.

Your registrar is eName per the WhoIs


i have already updated my dns record but still get the same error

Can we clarify whether you actually own kai.com? Like, did you buy it from a domain registrar? Or did you buy it off a previous registrant?

Or did you decide to use it, without owning it?


i created windows server 2019 and created my own domain server and created the dns record from it,
is it wrong to do that or i need to created a domain from a local website

If you create your own DNS server and add kai.com to it, that doesn't mean you own kai.com.

Let's Encrypt uses the real world DNS hierarchy to determine who controls a domain name. I think, based on your posts so far, that somebody else owns the domain. You cannot have a Let's Encrypt SSL certificate for a domain that you do not control.


what if i create a domain that no one owns it will it work? or i have to buy from domain registrar for it to work?

Yes, you have to buy a domain.


so once i buy a domain,and put dns record my red hat server the certbot will work?
and where can i buy a domain

Yes, that's the right idea, as long as your Red Hat server is accessible from the internet (not on a private network).

You can buy a domain from anywhere you want, it doesn't especially matter. I can suggest Cloudflare, Google Domains and Porkbun.


It won't be KAI.COM:


can i check as i saw alot of different domain with different prices, does the cheapest domain name will work too?

Yep. You can also get free domains from Freenom, if you want to experiment.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.