"Certbot Renew" can't work when we have multiple domain on the server?

My domain is:nguyenphudung.com

I ran this command: Certbot Renew
But I can't auto renew when my server has about than 10 other domains.
Then I use command "certbot --nginx -d vlxdkieuoanh[.]com -d www.vlxdkieuoanh[.]com" for each domain. It takes a long time.
How to renew easy than.

My web server is (include version): Nginx

The operating system my web server runs on is (include version): Centos 7

1 Like

Multiple domains should not be an issue. Could you please elaborate more about what issue you're running into? "Can't work" or "It takes a long time" doesn't say very much. Please post exact error messages or preferably log files of the issue.


Hi @nguyenphudung93dn, welcome to the LE community forum :slight_smile:

If certbot was already able to get a cert, they should all be renewed (when necessary) by the single command:

1 Like

Because I used command "certbot --nginx -d vlxdkieuoanh.com -d www.vlxdkieuoanh.com" for each domain. So I can't show you my problem. I think I will take a snapshot for next time. It will display exactly my problems. Thanks for all.

1 Like

So you didn't even try running certbot renew? If that's the case, why do you say that "can't work"? And why did you mark this topic as solved when neither you nor we have solved anything?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.