Certbot: Non-snapd instructions?

is there a way to get the snap version that works with python3? 2.7 is EOL, and I can't be the only one that isn't allowed to use python2.
I tried different ways, but it's always py2


Could you explain a little bit more @scavengineer? Because I'm not really following.. Certbot doesn't support Python 2.7 any more at all and it only runs on Python 3.x nowadays.


when I followed the snap instructions, the finished certbot failed, as it was trying to run a py27 certbot on a machine that does not have py27.
Once I realized that snap was installing a bad version, I did a thorough cleanup of the py27 certbot. As I recall the certbot.py was a symlink to certbot-2 which had as the first line:
When I changed it to /usr/bin/python3 it failed with lots of py27 mentions.
I will see if I still have any artifacts left over from that snap stuff . ...

1 Like

the certbot-2 is still on the machine:
cat /usr/bin/certbot-2
# EASY-INSTALL-ENTRY-SCRIPT: 'certbot==0.31.0','console_scripts','certbot'
requires = 'certbot==0.31.0'
import sys
from pkg_resources import load_entry_point

if __name__ == '__main__':
        load_entry_point('certbot==0.31.0', 'console_scripts', 'certbot')()
1 Like

Hmm. possible PEBKAC. That file is left over from when I converted everything from py27 to py3. Maybe the snap install didn't put it there.
maybe the system wasn't sufficiently clean before I ran the snap install.

1 Like

Yes, I can confirm the problem was on my end. Sorry for creating any confusion


It's recommended to have just one instance of certbot installed. So before installing certbot through snap (or pip or any method of installation really), it's best to remove the certbot installed through any other means. (For future readers coming across this thread.)


Thank you for acknowledging the future readers of these threads. :smiley:


snap is installed on a fresh install of Ubuntu 20.04.2

so I figure it is ok to use

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.