Certbot 'Namespace' object has no attribute 'certbot_plugin_gandi:dns_credentials'

Hello everyone,
A couple of years ago I've installed Let's Encrypt certificates on an apache server running on debian 11. I installed and managed the certificates using CertBot. As my web site provider is Gandi, I've followed this blog to set up CertBot.
Everything run nicely and smoothly until some weeks ago when I upgraded from debian 11 to debian 12 (bookworm). At that point I realised that CertBot stop working.
When I try to renew the certificate using certbot renew the following error is triggered:

Renewal configuration file /etc/letsencrypt/renewal/example.org.conf (cert: example.org) produced an unexpected error: 'Namespace' object has no attribute 'certbot_plugin_gandi:dns_credentials'. Skipping.

I'm using Apache/2.4.57 running on Debian GNU/Linux 12 (bookworm).

Can anybody help with this?

Hi @shevek, and welcome to the LE community forum :slight_smile:

Have you tried reinstalling certbot?
Have you tried updating certbot to the latest version?


python3-certbot-dns-gandi package has it it looks like


When you opened this thread in the Help section, you should have been provided with a questionnaire. Maybe you didn't get it somehow (which is weird), or you've decided to delete it. In any case, all the answers to this questionnaire are required:

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Especially because I'd like to know the version of Certbot you're using. The method of plugin_name:variable has been deprecated for a long time now and has been removed somewhere along the line.


It wasn't... I moved it here:


Ooeeh you sneaky..! :stuck_out_tongue:


Yep, he was. :slight_smile:

1 Like

Thank you very much @rg305 and @orangepizza. I've uninstalled an reinstalled certbot and then I followed these instructions (mentioned above by @orangepizza) and everything worked smoothly.
Thanks again, I've appreciated that!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.