Certbot is blocked on port 80

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: knightsofsor-reath.com

I ran this command: certbot certonly --standalone -d knightsofsor-reath.com

It produced this output: Certbot failed to authenticate some domains (authenticator: standalone). The Certificate Authority reported these problems:
Domain: knightsofsor-reath.com
Type: connection
Detail: Fetching http://knightsofsor-reath.com/.well-known/acme-challenge/FlIwRo5tw6kCSeSAyVfS0ne3mJisAVJecIS7BeDQwWs: Connection refused

Hint: The Certificate Authority failed to download the challenge files from the temporary standalone webserver started by Certbot on port 80. Ensure that the listed domains point to this machine and that it can accept inbound connections from the internet.

Some challenges have failed.

My web server is (include version): not sure, running node.js self hosted foundryVTT

The operating system my web server runs on is (include version): win10

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

i have port 80 and 443 forwarded. according to the ssl instructions on foundry site.

And what version are you running? The debug options are different in newer Versions


This is what I am seeing.

curl: (7) Failed to connect to knightsofsor-reath.com port 80 after 117 ms: Connection refused
80/tcp    closed http
443/tcp   closed https
30000/tcp open   ndmps


i fixed my ports and it worked. thanks for pointing out my error.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.