Certbot failing in renewing certificate After 10 months

Hi there,
I used so far for more than 1 year certbot to automatically create certificate for NodeRed access over Let's Certificate.
Unluckly even if the certificate update is supposed to be renews on a 30 days before the current certificate is going to expire, it is now since 2,5 months the certificate is not being changed.
Forcing the certificate creation it is working properly but always creating a file elapsing on April, 2023 (on the 18th).
Do you have any idea why this is happening?

I did actually checked the log file comparing the last time the certification got renewed correctly and when it is failing now
The first difference i can found is the invalid status that you can see in the screenshot here attached.
Seems there is error in validating the data which I believe shall be connected to something failing on the whole process on the let's encrypt.
Any idea which could be the reason?
Thank you so much for any help.

1 Like

Hi @anmabi1984, and welcome to the LE community forum :slight_smile:

For now, the "400" is the main problem.

Please help us to help you.
And answer as much of the following as you know.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):


Hi All,
Seems I solved.
The problem I had deactivated a port forwarding rule on the router necessary to get the inbound connection necessary for the certificate renewal.
Hope this can be of help for someone else in the future.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.