Certbot failed to authenticate some domains ; It works for most of my domains but few of them not working

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: ajadberlin.de

I ran this command:certbot certonly -d ajadberlin.de --nginx --debug-challenges --dry-run

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Simulating a certificate request for ajadberlin.de

Challenges loaded. Press continue to submit to CA. Pass "-v" for more info about

Press Enter to Continue

Certbot failed to authenticate some domains (authenticator: nginx). The Certificate Authority reported these problems:
Domain: ajadberlin.de
Type: serverInternal
Detail: During secondary validation: Remote PerformValidation RPC failed

Hint: The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx server and that it is accessible from the internet.

Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letse

My web server is (include version): nginx version: nginx/1.18.0 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 20.04 LTS

My hosting provider, if applicable, is: GoDaddy

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):certbot 1.21.0

We have tried almost all the solution available on this forum.

The hostname aza-ab.de seems to be unregistered:

osiris@desktop ~ $ whois aza-ab.de
Domain: aza-ab.de
Status: free
osiris@desktop ~ $ 

Note that you cannot just try to get a certificate for any random domain name. The domain name needs to be registered in the public DNS and under your controle.


There's an "n" in your screenshot which is missing from the Certbot command.


My Bad :raised_hands: -- The issue was while creating this request I misspelled the domain name. I have the same issue with 3-4 more domains

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.