Certbot - Failed authorization procedure

I want to generate a Let's Encrypt certificate for my server, so that I can renew it automatically. I would like to point out that my domain name is entered correctly and that the A DNS record for this domain contain the correct IP address. contain the correct IP address, I also ping 8.8.8.8.

My domain is: testpbx.kabia.eu

I ran this command:

certbot --nginx -d testpbx.kabia.eu

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Please read the Terms of Service at
https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf. You must
agree in order to register with the ACME server at
https://acme-v02.api.letsencrypt.org/directory
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(A)gree/(C)ancel: a

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Would you be willing to share your email address with the Electronic Frontier
Foundation, a founding partner of the Let's Encrypt project and the non-profit
organization that develops Certbot? We'd like to send you email about our work
encrypting the web, EFF news, campaigns, and ways to support digital freedom.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
(Y)es/(N)o: n
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for testpbx.info.eu
Using default addresses 80 and [::]:80 ipv6only=on for authentication.
nginx: [warn] duplicate network "::0/0", value: "0", old value: "1" in /etc/nginx/sites-enabled/3cxpbx:14
nginx: [warn] "ssl_stapling" ignored, issuer certificate not found for certificate "/var/lib/3cxpbx/Bin/nginx/conf/Instance1/testpbx.info.eu-crt.pem"
Waiting for verification...
Cleaning up challenges
nginx: [warn] duplicate network "::0/0", value: "0", old value: "1" in /etc/nginx/sites-enabled/3cxpbx:14
nginx: [warn] "ssl_stapling" ignored, issuer certificate not found for certificate "/var/lib/3cxpbx/Bin/nginx/conf/Instance1/testpbx.info.eu-crt.pem"
Failed authorization procedure. testpbx.info.eu (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: 185.203.28.51: Fetching http://testpbx.info.eu/.well-known/acme-challenge/82VDIjmjQpI-ljtnkFsT8HpUvLytub6Obb7ox5GAzOg: Timeout during connect (likely firewall problem)

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: testpbx.info.eu
   Type:   connection
   Detail: 185.xxx.xx.xx: Fetching
   http://testpbx.info.eu/.well-known/acme-challenge/82VDIjmjQpI-ljtnkFsT8HpUvLytub6Obb7:
   Timeout during connect (likely firewall problem)

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.
 - Your account credentials have been saved in your Certbot
   configuration directory at /etc/letsencrypt. You should make a
   secure backup of this folder now. This configuration directory will
   also contain certificates and private keys obtained by Certbot so
   making regular backups of this folder is ideal.

My web server is (include version): Debian 10.11

The operating system my web server runs on is (include version): nginx/1.14.2

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.31.0

Check if you have some <Location ... > block interfering somewhere in your Apache config.

❯ curl -IL http://testpbx.info.eu/.well-known/acme-challenge/
HTTP/1.1 404 Not Found
Date: Fri, 13 May 2022 11:05:15 GMT                                    
Server: Apache/2.4.25 (Debian)
Content-Type: text/html; charset=iso-8859-1

❯ curl -IL http://testpbx.info.eu/.well-known/acme-challenge
HTTP/1.1 404 Not Found
Date: Fri, 13 May 2022 11:05:18 GMT
Server: Apache/2.4.25 (Debian)
Upgrade: h2,h2c
Connection: Upgrade
Content-Type: text/html; charset=UTF-8

Also, yes, Apache is serving your site. Not nginx. Why are you running both?

1 Like