Certbot exiting with error: ConnectionError: ('Connection aborted.', error("(60, 'ETIMEDOUT')",))

@jsha, is there any chance that this weird hard-to-reproduce API connection failure is actually an endpoint/CDN issue?

Definitely doesn't have the characteristics of an endpoint connectivity error.

@tcv, I notice from your posted output that this happens in manual mode, after configuring your validation file and hitting enter. Am I correct in assuming it never happens before that? One reason that might be different is that Certbot uses a requests.session to pool HTTPS connections and reuse them. So in this scenario, Certbot may attempt to reuse a connection that was opened many minutes ago and has since timed out. The requests library should handle that gracefully (and does implement retries, I think), but perhaps there is a strange issue here.

Are there any firewalls on your machine, or between your machine and the Internet?

This makes it look like you do have an IPv6 address. Am I misunderstanding?

Thanks for looking into this, @jsha.

The fe80 address is a link-local address.


Awesome catch @schoen

Hi @jsha,

You are correct that this only happens after the validation file is configured and I hit enter.

Since the certbot I ran from docker-compose (the one with the hacky retry logic) worked, I thought Iā€™d try running the certbot installed on my system (with no changes - hacky retry logic, extra debug statements or otherwise) but alas, it failed as it always has with ETIMEDOUT error.

Iā€™m happy to make additional changes to help debug this issue.

There are no firewalls on my machine or between my machine and the Internet.

Thanks again for all the help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.