Certbot error with Dns

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: gotomeetings.net

I ran this command: bash bbb-install.sh…

It produced this output:

DNS problem: Servfail looking up for a gotomeetings.net

My web server is (include version): BigBlueButton

The operating system my web server runs on is (include version):LINUX ubuntu 16.04

My hosting provider, if applicable, is: TLH

I can login to a root shell on my machine (yes or no, or I don’t know): I dont know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): Latest version în scrypt

I got a certificate for my bbb server but i removed him from the server because i make other one on a PC and when i tried again to run the scrypt, gave me that error with DNS. Plecase can someone help? I did a local DNS server but nothing

Your domain is unresolvable, because ns1.gotomeetings.net and ns2.gotomeetings.net don’t have any glue records.

If you have IP addresses for those two nameservers, you should sign in to your domain registrar (Enom?) and set the glue records for them there.

Thank you for replay.
The solution îs to assign my ip to nameservers domain on my provider?

I don’t know. Who is your DNS host?

If you are self-hosting your own nameservers, then yes, I guess that’s what you should do.

Yes, i have my own server and i bought a domain. I set a DNS local server on my linux server and when i run nslookup gotomeetings.net and nslookup 193.168.1.105 all works fine

Now i check my site on internat and i sow my DNSSEC ia unsigned.

OK. So now you have glue records (pointing to 86.127.56.58), that’s a good step.

However, your server is not responding to DNS queries for your domain.

If you’re self-hosting your own DNS, you need to set it up as a public authoritative server, so that Let’s Encrypt (and other people) can query for your domain’s IP address.

Can you help me with some details, how i can do it? I donw know too much about this.
Thank you again for your reply.

If you don’t know how to setup your own authoritative nameserver, I suggest using an existing DNS hosting service instead.

I’m sure Enom offers DNS hosting with your domain registration, and there’s a lot of other choices.

Thank you for help.
I found the problem. I bought from my network provider 1 more ip, but they change my external ip 85.127.56.58 in other one and my nameservers was still on that IP. I change the current ip of my nameservers on the domain provider with new one and works.
I sow what you said with my ip and i checked it again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.