Certbot error. Unauthorized

My domain is:pingoo.in

I ran this command: sudo certbot --apache -d pingoo.in

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for pingoo.in
Enabled Apache rewrite module
Waiting for verification...
Cleaning up challenges
Failed authorization procedure. pingoo.in (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from Pingoo-Passive income on the go [45.90.109.167]: "<!doctype html><html lang="en"><meta charset="utf-8"/><link rel="icon" href="./favicon.ico"/><meta name="viewport" content"

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: pingoo.in
    Type: unauthorized
    Detail: Invalid response from
    Pingoo-Passive income on the go
    [45.90.109.167]: "<!doctype html><html lang="en"><meta
    charset="utf-8"/><link rel="icon" href="./favicon.ico"/><meta
    name="viewport" content"

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address.

My web server is (include version): apache 2.4.18

The operating system my web server runs on is (include version): ubuntu 16.04

My hosting provider, if applicable, is: hostinger

I can login to a root shell on my machine (yes or no, or I don't know):yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):0.31.0

1 Like

Welcome to the Let's Encrypt Community :slightly_smiling_face:

I'm seeing some problems with your nameservers.

1 Like

Hi @pingo-psynergy

if that doesn't work, instead, if this

is the answer, Certbot doesn't understand your vHost config.

What says

apachectl -S

PS: Your name servers are buggy, see pingoo.in - Make your website better - DNS, redirects, mixed content, certificates

Nameserver Timeout checking Echo Capitalization: 1123.dns4.managedns.org

That will block your CAA - check, if the domain validation has worked.

But it's not your current error message. May be remove (only) the third, not working name server 1123.dns4.managedns.org. You have two other, that's enough.

That may remove the Letsdebug error.

2 Likes

I'm also wondering if your Apache is listening directly (as opposed to behind a reverse proxy, or something), since the server there did not specifically identify itself as Apache.

2 Likes

I wondered the same thing, @schoen. I thought that was odd.

1 Like

Hi All,

I am using a sprint boot application(which internally installs apache) and haven't configured anything in vhost. But the application is running because I am using iptables to forward requests from 80 to 8080(server port). Is there any other way to deploy it. If yes, Can you please let me know. Thankyou in advance

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.