Certbot disabled php and virtual hosts

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: bionsmalley.com and bionware.com

I ran this command: installed certbot and ran it to create certificates

It produced this output: certificates created

My web server is (include version): Apache 2.4.41 (Win64)

The operating system my web server runs on is (include version): Windows 10 Pro 10.0.18363

My hosting provider, if applicable, is: (self)

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):1.7.0

2 Likes

Immediately after installing and running Certbot to successfully create certificates, but BEFORE modifying the Apache configuration for https, my websites stopped working. PHP seems to be disabled now and Apache is no longer recognizing virtual hosts. Did installing Certbot cause some existing dll files to be overwritten, or were any environmental variables or registry values overwritten? Right now I can’t even restore the old existing websites. Help!

1 Like

Welcome to the Let’s Encrypt Community :slightly_smiling_face:

Without knowing the specific parameters you used for certbot, we’re working rather blind here.

It could be that apache was shut down due to using standalone.

Try running certbot rollback to restore your functionality. You can run it more than once to incrementally roll-back.

Chances are that your configuration may have started with some complexities that mixed poorly certbot’s changes. To my knowledge, certbot only makes configuration changes and does not modify your binaries and such.

1 Like

Thanks for the reply. It seems that somehow around the time of the Certbot installation process, an Apache configuration file was inadvertently altered – unrelated to the Certbot install.
So this is a false alarm. Sorry. I would delete the whole thread if I knew how.

1 Like

No worries. You don’t need to delete it, but if you want to you can click the three dots at the bottom of your initial post and then click the trash can.

I tried to delete, but the trashcan tells me I don’t have permission. Oh well …

1 Like

No worries then. And good luck. :slightly_smiling_face: