Certbot certonly -standalone failed to authenticate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: app.gymsource.com

I ran this command: certbot certonly --standalone

It produced this output:
Requesting a certificate for app.gymsource.com

Certbot failed to authenticate some domains (authenticator: standalone). The Certificate Authority reported these problems:
Domain: app.gymsource.com
Type: connection
Detail: 40.70.25.214: Fetching http://app.gymsource.com/.well-known/acme-challenge/aorGvAW17SDK01Hwc0JvUFJ8VmDaiv026I9vZlLKtzA: Timeout during connect (likely firewall problem)

Hint: The Certificate Authority failed to download the challenge files from the temporary standalone webserver started by Certbot on port 80. Ensure that the listed domains point to this machine and that it can accept inbound connections from the internet.

Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile C:\Certbot\log\letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): IIS V10

The operating system my web server runs on is (include version): Windows Server 2019

My hosting provider, if applicable, is: Azure Cloud

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.24.0

Hi @lesvipani, and welcome to the LE community forum :slight_smile:

It "works" from my IP and from:
Let's Debug (letsdebug.net)

Try again, if it continues to fail with:

You should then check for anything within that system that can Geolocation block or ban specific IPs.

2 Likes

Thank you @rg305 for reviewing and providing the input.

I had forgotten to mention that I had shutdown IIS server before running the too. Which I believe is what was expected per instructions.

I tried again and no luck.

I am newbie with the tool. Is the tool looking for ".well-know/acme-challenge" folder in the inetpub/wwwroot folder? If it is, there is no folder by the name.

1 Like

It looks for /.well-known/acme-challenge/{actual token} within the document root folder.
If that is inetpub/wwwroot in your system, I would not know.

1 Like

The --standalone plugin does not do that.

2 Likes

True; I missed that:

1 Like