Certbot breaks/blocks website

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: rycoh.net

I ran this command: sudo certbot --nginx -d rycoh.net

It produced this output:

My web server is (include version): nginx/1.18.0

The operating system my web server runs on is (include version): Ubuntu 20.04.5 LTS

My hosting provider, if applicable, is: Space Hosting

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

Hello, whenever I try to run the command to run certbot, it always says "Timeout during connect (likely firewall problem)", port 80 and 443 are both accessible, and firewall is fully disabled until I fix this issue, running certbot with this command line: sudo certbot certonly --nginx -d rycoh.net --dry-run --debug-challenges -v parameters, works, until I actually press enter to continue ("submit to CA"), after that the website stops working and if I try to access it from my browser it returns "ERR_CONNECTION_REFUSED".
I'm not really sure if I'm doing something wrong myself or something is broken, I've been trying to fix it for the past hours, and I haven't gotten anything and didn't found anyone with the same issue either. If you need some logs let me know and I will upload them. Thank you!

1 Like

Welcome @Rycoh

Have you fixed the problem? Because I can't reproduce what you describe.

The Let's Debug test site (link here) shows all is well and it also uses the Let's Encrypt staging system like you do for your --dry-run test.

I also probed your site for various problems and don't see any connection issues.


Hello again, I ended up updating Certbot (I was using the old deprecated apt version), now everything works as it should! I don't know how I missed checking this, also, how can I mark this post as "solved"?
Thank you again!


You can select a post and mark it as "solution" (which I already did). Cheers


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.