Certbot-auto fails while setting up virtual environment, complains about package hashes


#21

Dudes, this helps:

diff --git a/letsencrypt-auto b/letsencrypt-auto
index 80f39cf..6ebadb1 100755
--- a/letsencrypt-auto
+++ b/letsencrypt-auto
@@ -574,8 +574,6 @@ argparse==1.4.0 \
 
 # This comes before cffi because cffi will otherwise install an unchecked
 # version via setup_requires.
-pycparser==2.14 \
-    --hash=sha256:7959b4a74abdc27b312fed1c21e6caf9309ce0b29ea86b591fd2e99ecdf27f73
 
 cffi==1.4.2 \
     --hash=sha256:53c1c9ddb30431513eb7f3cdef0a3e06b0f1252188aaa7744af0f5a4cd45dbaf \
@@ -912,6 +910,8 @@ UNLIKELY_EOF
     # Set PATH so pipstrap upgrades the right (v)env:
     PATH="$VENV_BIN:$PATH" "$VENV_BIN/python" "$TEMP_DIR/pipstrap.py"
     set +e
+    #XXX
+    $VENV_BIN/pip install git+https://github.com/eliben/pycparser@release_v2.14
     PIP_OUT=`"$VENV_BIN/pip" install --no-cache-dir --require-hashes -r "$TEMP_DIR/letsencrypt-auto-requirements.txt" 2>&1`
     PIP_STATUS=$?
     set -e

As a tmp solution, of course.


#22

Thanks, murchik. It works.


#23

I am so sorry I had a copy paste fail.

What is meant to write was

pip install pycparser==2.13

I downgraded my pycparser to 2.13 and then I could install cryptography fine

pip install cryptography


#24

Adding “–no-binary pycparser” as recommended in the pycparser git issue tracker worked for me on a Raspberry Pi with Raspbian Jessie:

Change certbot-auto as follows:

diff --git a/certbot-auto b/certbot-auto
index 80f39cf..aba3a28 100755
--- a/certbot-auto
+++ b/certbot-auto
@@ -575,7 +575,8 @@ argparse==1.4.0 \
 # This comes before cffi because cffi will otherwise install an unchecked
 # version via setup_requires.
 pycparser==2.14 \
-    --hash=sha256:7959b4a74abdc27b312fed1c21e6caf9309ce0b29ea86b591fd2e99ecdf27f73
+    --hash=sha256:7959b4a74abdc27b312fed1c21e6caf9309ce0b29ea86b591fd2e99ecdf27f73 \
+    --no-binary pycparser

 cffi==1.4.2 \
     --hash=sha256:53c1c9ddb30431513eb7f3cdef0a3e06b0f1252188aaa7744af0f5a4cd45dbaf \

#25

I confirm @seadog 's fix works on Ubuntu 14.04 LTS aswell.


#26

I confirm @seadog fix too, worked on Ubuntu 14.04. Thanks!


#27

Even i am facing the same issue . in ubuntu 14.04,


#28

I also confirm that @seadog 's fix works on Ubuntu 14.04 LTS. You have to modify your certbot-auto script and add that one line after --hash=sha256... like so:

pyparser==2.14 \ --hash=sha256:7959b4a74abdc27b312fed1c21e6caf9309ce0b29ea86b591fd2e99ecdf27f73 \ --no-binary pycparser

instead of:

pyparser==2.14 \ --hash=sha256:7959b4a74abdc27b312fed1c21e6caf9309ce0b29ea86b591fd2e99ecdf27f73 \


#29

Hey! @pfzero

please let me how edit that file in ubuntu…


#30

i confirm @seadog fix too, it worked on Ubuntu 14.04,

sudo nano certbot-auto search for : pycparser==2.14 in the file

add --no-binary pycparser

below --hash=sha256:7959b4a74abdc27b312fed1c21e6caf9309ce0b29ea86b591fd2e99ecdf27f73 \

save the file and execute it

Thanks!


#31

Issue has been resolved :slight_smile:


#32

Phew. @nickschwab is correct that this issue has been resolved. For those that are curious, I wrote up a bit of a postmortem about what happened on our GitHub repo:


#33

Nicely done Sir!

Thank you very much

Mike


#34

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.